summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-01-26 12:30:25 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-01-26 12:30:25 +0000
commitbb05ab39aabf50db42686363962d40245f33fa75 (patch)
tree06db0c0785cb5443203ab1679db10dcf23d30d11 /app-crypt/bcwipe
parentAdd selinux to IUSE, we use it in *DEPEND. (diff)
downloadgentoo-2-bb05ab39aabf50db42686363962d40245f33fa75.tar.gz
gentoo-2-bb05ab39aabf50db42686363962d40245f33fa75.tar.bz2
gentoo-2-bb05ab39aabf50db42686363962d40245f33fa75.zip
Version bump, bug#207541, thanks to wschlich
(Portage version: 2.1.4)
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/ChangeLog7
-rw-r--r--app-crypt/bcwipe/bcwipe-1.7_p2.ebuild44
-rw-r--r--app-crypt/bcwipe/files/digest-bcwipe-1.7_p26
3 files changed, 56 insertions, 1 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index 20e1dfd33210..04e1ea452e2c 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.24 2008/01/02 15:37:28 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.25 2008/01/26 12:30:25 alonbl Exp $
+
+*bcwipe-1.7_p2 (26 Jan 2008)
+
+ 26 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> +bcwipe-1.7_p2.ebuild:
+ Version bump, bug#207541, thanks to wschlich
02 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> -bcwipe-1.5_p3.ebuild,
-bcwipe-1.6_p1.ebuild:
diff --git a/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild b/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild
new file mode 100644
index 000000000000..34f3f34ff7b4
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild,v 1.1 2008/01/26 12:30:25 alonbl Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV="${PV/_p/-}"
+
+DESCRIPTION="BCWipe secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ http://www.jetico.com/linux/BCWipe.doc.tgz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEFS="${CFLAGS}"|| die "Make failed"
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [ -f testfile ] && die "test file still exists. bcwipe should of deleted it"
+}
+
+src_install() {
+ dobin bcwipe
+ doman bcwipe.1
+ use doc && dohtml -r ../bcwipe-help
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/digest-bcwipe-1.7_p2 b/app-crypt/bcwipe/files/digest-bcwipe-1.7_p2
new file mode 100644
index 000000000000..74ab3611f945
--- /dev/null
+++ b/app-crypt/bcwipe/files/digest-bcwipe-1.7_p2
@@ -0,0 +1,6 @@
+MD5 772d9124760508c73ee8ed7d84ea030e BCWipe-1.7-2.tar.gz 26818
+RMD160 0e451319262459a2cb16bc0e4534e83cbb05ca84 BCWipe-1.7-2.tar.gz 26818
+SHA256 d03da7638363f732701ccbe24fd368ca61da75d59665e927a75de0742738d328 BCWipe-1.7-2.tar.gz 26818
+MD5 f095c187949d08a3cc3b245862df9acd BCWipe.doc.tgz 21218
+RMD160 a38bb741c3aae7d849cc8035010644720434ac2b BCWipe.doc.tgz 21218
+SHA256 afa50bf8653bb6bee108f0ae8b3dc35d289dde3d5c513b7e9ae7fe373635df4f BCWipe.doc.tgz 21218