summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-02 17:27:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-02 17:27:20 +0000
commiteefdb845a58ea238e0f0464fe410481a5896612c (patch)
treeb1ee66b79935121374e97b9015e6d2bdff63b98b /app-crypt/bestcrypt
parentppc stable #268187 (diff)
downloadgentoo-2-eefdb845a58ea238e0f0464fe410481a5896612c.tar.gz
gentoo-2-eefdb845a58ea238e0f0464fe410481a5896612c.tar.bz2
gentoo-2-eefdb845a58ea238e0f0464fe410481a5896612c.zip
Version bump.
(Portage version: 13595-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/bestcrypt')
-rw-r--r--app-crypt/bestcrypt/ChangeLog10
-rw-r--r--app-crypt/bestcrypt/bestcrypt-1.7.0.ebuild82
-rw-r--r--app-crypt/bestcrypt/files/bestcrypt-1.7.0-respect_LDFLAGS.patch86
3 files changed, 176 insertions, 2 deletions
diff --git a/app-crypt/bestcrypt/ChangeLog b/app-crypt/bestcrypt/ChangeLog
index c064cb742f76..171bec71a153 100644
--- a/app-crypt/bestcrypt/ChangeLog
+++ b/app-crypt/bestcrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bestcrypt
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.66 2008/05/01 18:12:38 alonbl Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.67 2009/05/02 17:27:20 arfrever Exp $
+
+*bestcrypt-1.7.0 (02 May 2009)
+
+ 02 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bestcrypt-1.7.0.ebuild, +files/bestcrypt-1.7.0-respect_LDFLAGS.patch:
+ Version bump.
01 May 2008; Alon Bar-Lev <alonbl@gentoo.org> -bestcrypt-1.6_p15.ebuild:
Cleanup
diff --git a/app-crypt/bestcrypt/bestcrypt-1.7.0.ebuild b/app-crypt/bestcrypt/bestcrypt-1.7.0.ebuild
new file mode 100644
index 000000000000..77b0fc3f6196
--- /dev/null
+++ b/app-crypt/bestcrypt/bestcrypt-1.7.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/bestcrypt-1.7.0.ebuild,v 1.1 2009/05/02 17:27:20 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic linux-mod toolchain-funcs versionator
+
+MY_PN="bcrypt"
+MY_PV="$(replace_version_separator 2 -)"
+DESCRIPTION="commercially licensed transparent filesystem encryption"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BestCrypt-${MY_PV}.tar.gz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="bc(block:mod)
+ bc_3des(block:mod:mod/3des)
+ bc_bf128(block:mod:mod/bf128)
+ bc_bf448(block:mod:mod/bf448)
+ bc_blowfish(block:mod:mod/blowfish)
+ bc_cast(block:mod:mod/cast)
+ bc_des(block:mod:mod/des)
+ bc_gost(block:mod:mod/gost)
+ bc_idea(block:mod:mod/idea)
+ bc_rijn(block:mod:mod/rijn)
+ bc_twofish(block:mod:mod/twofish)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS=" \
+ CPP=\"$(tc-getCXX)\" \
+ KERNEL_DIR=\"${KV_DIR}\" \
+ VER=${KV_MAJOR}.${KV_MINOR} \
+ KEXT=${KV_OBJ}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respect_LDFLAGS.patch"
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ filter-flags -fforce-addr
+
+ emake BC_CPP="$(tc-getCXX)" EXTRA_CFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dobin build/bctool
+ dolib.so build/lib{bccore,kgsha{,256}}.so
+ local link
+ for link in bcmount bcumount bcformat bcfsck bcnew bcpasswd bcinfo bclink bcunlink bcmake_hidden bcreencrypt; do
+ dosym bctool "/usr/bin/${link}"
+ done
+ insinto /etc
+ newins etc/bc.conf bc.conf
+ newinitd "${FILESDIR}/bcrypt3" bcrypt
+ dodoc HIDDEN_PART README
+ doman man/bctool.8
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn
+
+ linux-mod_pkg_postinst
+}
diff --git a/app-crypt/bestcrypt/files/bestcrypt-1.7.0-respect_LDFLAGS.patch b/app-crypt/bestcrypt/files/bestcrypt-1.7.0-respect_LDFLAGS.patch
new file mode 100644
index 000000000000..e07cb3e5ff58
--- /dev/null
+++ b/app-crypt/bestcrypt/files/bestcrypt-1.7.0-respect_LDFLAGS.patch
@@ -0,0 +1,86 @@
+--- Makefile
++++ Makefile
+@@ -37,7 +37,7 @@
+ BC_CPP = g++
+ BC_CFLAGS = -Wall -fno-strict-aliasing -I$(FRAMEWORK_PATH) $(EXTRA_CFLAGS) -DBC_BACKEND_HAS_PIO
+
+-LDFLAGS = -Wl,-whole-archive,$(BC_BUILD)/$(BACKEND),$(BC_BUILD)/$(TOOLS),-no-whole-archive -L$(BC_BUILD) -lbccore
++LIBS = -Wl,-whole-archive,$(BC_BUILD)/$(BACKEND),$(BC_BUILD)/$(TOOLS),-no-whole-archive -L$(BC_BUILD) -lbccore -ldl
+
+ # main target
+ # build subtargets and core
+@@ -46,14 +46,14 @@
+
+ release: Makefile
+ set -e; for i in $(SUBDIRS); do $(MAKE) -C $$i BC_BUILD="$(BC_BUILD)" BC_CPP=$(BC_CPP) BC_CFLAGS="$(BC_CFLAGS)"; done
+- $(BC_CPP) $(LDFLAGS) -o $(BC_BUILD)/$(TARGET)
++ $(BC_CPP) $(LDFLAGS) -o $(BC_BUILD)/$(TARGET) $(LIBS)
+
+ debug: Makefile
+ set -e; for i in $(SUBDIRS); do $(MAKE) -C $$i BC_BUILD="$(BC_BUILD)" BC_CPP=$(BC_CPP) BC_CFLAGS="$(BC_CFLAGS) -pg -DBC_DEBUG"; done
+- $(BC_CPP) $(LDFLAGS) -o $(BC_BUILD)/$(TARGET)
++ $(BC_CPP) $(LDFLAGS) -o $(BC_BUILD)/$(TARGET) $(LIBS)
+
+
+-# subtragets build
++# subtargets build
+ subdirs:
+
+ install: subdirs
+--- core/Makefile
++++ core/Makefile
+@@ -23,7 +23,8 @@
+ # build flags
+ CFLAGS = -fPIC
+ CFLAGS += $(BC_CFLAGS)
+-LDFLAGS = -shared -Wl,-soname,$(DYNAMIC) -Wl,-whole-archive,$(LOCAL_BUILD)/$(STATIC),-no-whole-archive -ldl
++LDFLAGS += -shared -Wl,-soname,$(DYNAMIC)
++LIBS = -Wl,-whole-archive,$(LOCAL_BUILD)/$(STATIC),-no-whole-archive -ldl
+
+
+ # ----------------------------------------------------------
+@@ -35,7 +36,7 @@
+
+
+ $(DYNAMIC): $(STATIC) Makefile
+- $(BC_CPP) $(LDFLAGS) -o $(LOCAL_BUILD)/$(DYNAMIC)
++ $(BC_CPP) $(LDFLAGS) -o $(LOCAL_BUILD)/$(DYNAMIC) $(LIBS)
+
+
+ $(STATIC):
+--- core/mod/v7/kgsha/Makefile
++++ core/mod/v7/kgsha/Makefile
+@@ -20,12 +20,13 @@
+ TARGET = libkgsha.so
+ OBJ = sha1.o random.o sha1defs.o
+ COMMON = ../libkgsha_common.a
+-LDFLAGS = -shared -Wl,-soname,$(TARGET) -Wl,-whole-archive,$(COMMON),-no-whole-archive
++LDFLAGS += -shared -Wl,-soname,$(TARGET)
++LIBS = -Wl,-whole-archive,$(COMMON),-no-whole-archive
+
+ all: $(TARGET) Makefile
+
+ $(TARGET):$(OBJ)
+- $(CPP) $(OBJ) $(LDFLAGS) -o $(TARGET)
++ $(CPP) $(OBJ) $(LDFLAGS) -o $(TARGET) $(LIBS)
+ $(CP) $(TARGET) $(BUILD_PATH)
+
+ %.o: %.cpp
+--- core/mod/v7/kgsha256/Makefile
++++ core/mod/v7/kgsha256/Makefile
+@@ -21,12 +21,13 @@
+ TARGET = libkgsha256.so
+ OBJ = sha256.o random.o sha256defs.o
+ COMMON = ../libkgsha_common.a
+-LDFLAGS = -shared -Wl,-soname,$(TARGET) -Wl,-whole-archive,$(COMMON),-no-whole-archive
++LDFLAGS += -shared -Wl,-soname,$(TARGET)
++LIBS = -Wl,-whole-archive,$(COMMON),-no-whole-archive
+
+ all: $(TARGET) Makefile
+
+ $(TARGET):$(OBJ)
+- $(CPP) $(OBJ) $(LDFLAGS) -o $(TARGET)
++ $(CPP) $(OBJ) $(LDFLAGS) -o $(TARGET) $(LIBS)
+ $(CP) $(TARGET) $(BUILD_PATH)
+
+ %.o: %.cpp