summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2014-06-26 19:57:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2014-06-26 19:57:03 +0000
commitca1b75656588e877ee85ce667bc12442b91bae68 (patch)
treeab245cc07f3544dfe23afc418170fa3763d1e729 /app-crypt/ccid
parentVersion bump to Rails 4.0.6. (diff)
downloadgentoo-2-ca1b75656588e877ee85ce667bc12442b91bae68.tar.gz
gentoo-2-ca1b75656588e877ee85ce667bc12442b91bae68.tar.bz2
gentoo-2-ca1b75656588e877ee85ce667bc12442b91bae68.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/ChangeLog7
-rw-r--r--app-crypt/ccid/ccid-1.4.17.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-crypt/ccid/ChangeLog b/app-crypt/ccid/ChangeLog
index 5144a7639f47..779c7494a799 100644
--- a/app-crypt/ccid/ChangeLog
+++ b/app-crypt/ccid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ccid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.108 2014/04/20 11:21:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.109 2014/06/26 19:57:03 flameeyes Exp $
+
+*ccid-1.4.17 (26 Jun 2014)
+
+ 26 Jun 2014; Diego E. Pettenò <flameeyes@gentoo.org> +ccid-1.4.17.ebuild:
+ Version bump.
20 Apr 2014; Agostino Sarubbo <ago@gentoo.org> ccid-1.4.15.ebuild:
Stable for ppc64, wrt bug #505892
diff --git a/app-crypt/ccid/ccid-1.4.17.ebuild b/app-crypt/ccid/ccid-1.4.17.ebuild
new file mode 100644
index 000000000000..3b85f789ab65
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.4.17.ebuild,v 1.1 2014/06/26 19:57:03 flameeyes Exp $
+
+EAPI=5
+
+STUPID_NUM="4091"
+
+inherit eutils toolchain-funcs udev autotools-utils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ local myeconfargs=(
+ LEX=:
+ $(use_enable twinserial)
+ $(use_enable usb libusb)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+ fi
+}