summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-10-14 19:06:34 +0000
committerDane Smith <c1pher@gentoo.org>2012-10-14 19:06:34 +0000
commit7f0ae38acbff09ffd180dbc6af18b3354adfab2f (patch)
treea367dbbdf0a6620d22eeb1c46ed51897cf81524d /app-crypt/dieharder/dieharder-3.31.1.ebuild
parentPrepare for fortran2.eclass update (diff)
downloadgentoo-2-7f0ae38acbff09ffd180dbc6af18b3354adfab2f.tar.gz
gentoo-2-7f0ae38acbff09ffd180dbc6af18b3354adfab2f.tar.bz2
gentoo-2-7f0ae38acbff09ffd180dbc6af18b3354adfab2f.zip
Version bump wrt bug 411653.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/dieharder/dieharder-3.31.1.ebuild')
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1.ebuild b/app-crypt/dieharder/dieharder-3.31.1.ebuild
new file mode 100644
index 000000000000..941954637b33
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/dieharder/dieharder-3.31.1.ebuild,v 1.1 2012/10/14 19:06:34 c1pher Exp $
+
+EAPI=4
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/latex2html )"
+
+src_compile() {
+ emake all-recursive
+ use doc && emake -C manual
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NOTES
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES
+
+ if use doc ; then
+ dodoc ChangeLog dieharder.html
+ docinto "manual"
+ dodoc manual/dieharder.pdf manual/dieharder.ps
+ fi
+}