summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-01-22 21:09:06 +0000
committerRick Farina <zerochaos@gentoo.org>2013-01-22 21:09:06 +0000
commit708afcb53faa9f049b2214ed5ef50ef6fee6720a (patch)
treeb8eb423a65e4964a46968b5b8907a50505d82a88 /app-crypt/johntheripper
parentold (diff)
downloadgentoo-2-708afcb53faa9f049b2214ed5ef50ef6fee6720a.tar.gz
gentoo-2-708afcb53faa9f049b2214ed5ef50ef6fee6720a.tar.bz2
gentoo-2-708afcb53faa9f049b2214ed5ef50ef6fee6720a.zip
build fix for ppc, as reported and fixed by peratu and approved by upstream for this version. bug #452592
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-crypt/johntheripper')
-rw-r--r--app-crypt/johntheripper/ChangeLog8
-rw-r--r--app-crypt/johntheripper/files/johntheripper-1.7.9-ppc-compile-fix.patch17
-rw-r--r--app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/app-crypt/johntheripper/ChangeLog b/app-crypt/johntheripper/ChangeLog
index b29677c84d40..af6e6c370bc9 100644
--- a/app-crypt/johntheripper/ChangeLog
+++ b/app-crypt/johntheripper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/johntheripper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.152 2013/01/20 13:10:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.153 2013/01/22 21:09:06 zerochaos Exp $
+
+ 22 Jan 2013; Rick Farina <zerochaos@gentoo.org>
+ +files/johntheripper-1.7.9-ppc-compile-fix.patch,
+ johntheripper-1.7.9-r6.ebuild:
+ build fix for ppc, as reported and fixed by peratu and approved by upstream
+ for this version. bug #452592
20 Jan 2013; Agostino Sarubbo <ago@gentoo.org> johntheripper-1.7.9-r6.ebuild:
Stable for arm, wrt bug #450180
diff --git a/app-crypt/johntheripper/files/johntheripper-1.7.9-ppc-compile-fix.patch b/app-crypt/johntheripper/files/johntheripper-1.7.9-ppc-compile-fix.patch
new file mode 100644
index 000000000000..c28ec21a0ae8
--- /dev/null
+++ b/app-crypt/johntheripper/files/johntheripper-1.7.9-ppc-compile-fix.patch
@@ -0,0 +1,17 @@
+diff -ru john-1.7.9.orig/src/gost_plug.c john-1.7.9/src/gost_plug.c
+--- john-1.7.9.orig/src/gost_plug.c 2013-01-20 16:15:45.464000001 +0000
++++ john-1.7.9/src/gost_plug.c 2013-01-20 16:16:06.104000001 +0000
+@@ -531,7 +531,6 @@
+ }
+ #endif
+
+-#ifndef __GLIBC__
+ void rhash_u32_swap_copy(void* to, int index, const void* from, size_t length) {
+ size_t i;
+ unsigned int *pO, *pI;
+@@ -542,4 +541,3 @@
+ *pO++ = bswap_32(*pI++);
+ }
+ }
+-#endif
+
diff --git a/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild b/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild
index 2a4ff57c4f5b..d88e939ef0c7 100644
--- a/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild,v 1.6 2013/01/20 13:10:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.7.9-r6.ebuild,v 1.7 2013/01/22 21:09:06 zerochaos Exp $
EAPI="4"
@@ -141,6 +141,8 @@ src_prepare() {
# fix typo in jumbo patch
sed -i 's:All15:All5:' run/john.conf || die
+ # fix compile on ppc (only needed for jumbo-7)
+ epatch "${FILESDIR}/${P}-ppc-compile-fix.patch"
fi
cd src