summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-06-21 21:38:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-06-21 21:38:10 +0000
commita0fee3ace3b930c5081f18f48c811762a46a348c (patch)
tree583e1f67f2f72d79f2d26baddca2d884014352b6 /app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild
parentrevision bump bug #96101, cleanup (diff)
downloadgentoo-2-a0fee3ace3b930c5081f18f48c811762a46a348c.tar.gz
gentoo-2-a0fee3ace3b930c5081f18f48c811762a46a348c.tar.bz2
gentoo-2-a0fee3ace3b930c5081f18f48c811762a46a348c.zip
version bump, which also fixes the db-4 specific issue. I do not like it, for the record, but then the sys-libs/db package has always been a thorn in gentoo's side, so what else is new. Fixes bug #95549 by Justin Guyett <justin-gentoo@soze.net>
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild')
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild b/app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild
new file mode 100644
index 000000000000..c01187467d55
--- /dev/null
+++ b/app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.1.ebuild,v 1.1 2005/06/21 21:38:10 seemant Exp $
+
+inherit eutils flag-o-matic versionator
+
+MY_P=${P/mit-}
+P_DIR=$(get_version_component_range 1-2)
+S=${WORKDIR}/${MY_P}/src
+DESCRIPTION="MIT Kerberos V"
+HOMEPAGE="http://web.mit.edu/kerberos/www/"
+SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="krb4 static tcltk ipv6 doc tetex"
+
+RDEPEND="virtual/libc
+ !virtual/krb5"
+
+DEPEND="${RDEPEND}
+ sys-libs/com_err
+ sys-libs/ss
+ sys-devel/autoconf
+ >=sys-libs/db-4"
+
+PROVIDE="virtual/krb5"
+
+src_unpack() {
+ unpack ${A}; tar zxf ${MY_P}.tar.gz; cd ${S}
+ epatch ${FILESDIR}/${P}-lazyldflags.patch
+}
+
+src_compile() {
+ export DB_HEADER="/usr/include/db_185.h"
+ export DB_LIB="/usr/$(get_libdir)/libdb.so"
+
+ econf \
+ $(use_with krb4) \
+ $(use_with tcltk tcl) \
+ $(use_enable ipv6) \
+ $(use_enable static) \
+ --enable-shared \
+ --with-system-et --with-system-ss \
+ --with-system-db \
+ --enable-dns-for-realm || die
+
+ MAKEOPTS=-j1 emake || die
+
+ if use doc ; then
+ cd ../doc
+ rm man2html && ln -sf ${ROOT}/usr/bin/man2html
+
+ make || die
+
+ if use tetex ; then
+ cd api
+ make || die
+ fi
+ fi
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ EXAMPLEDIR=/usr/share/doc/${PF}/examples \
+ install || die
+
+ cd ..
+ dodoc README
+ doinfo doc/*.texinfo
+
+ if use doc
+ then
+ dohtml -r doc
+ use tetex \
+ && dodoc doc/api/*.{tex,sty} \
+ || dodoc doc/api/*.ps
+
+ fi
+
+ for i in {telnetd,ftpd}
+ do
+ mv ${D}/usr/share/man/man8/${i}.8 ${D}/usr/share/man/man8/k${i}.8
+ mv ${D}/usr/sbin/${i} ${D}/usr/sbin/k${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp}
+ do
+ mv ${D}/usr/share/man/man1/${i}.1 ${D}/usr/share/man/man1/k${i}.1
+ mv ${D}/usr/bin/${i} ${D}/usr/bin/k${i}
+ done
+
+
+
+
+
+ newinitd ${FILESDIR}/mit-krb5kadmind.initd mit-krb5kadmind
+ newinitd ${FILESDIR}/mit-krb5kdc.initd mit-krb5kdc
+
+ insinto /etc
+ doins ${FILESDIR}/k{rb5,dc}.conf
+}
+
+pkg_postinst() {
+
+ if use doc
+ then
+ einfo "See /usr/share/doc/${PF}/html/admin.html for documentation."
+ echo ""
+ fi
+ einfo "The client apps are installed with the mit- prefix"
+ einfo "(ie. mit-ftp, mit-ftpd, mit-telnet, mit-telnetd, etc...)"
+ echo ""
+}