summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-14 14:41:26 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-14 14:41:26 +0000
commit4b3de208b2b52b518d8acc7f975efc53523056f6 (patch)
tree576dad8e09b19d7dac4518845beac7b9ceef804b /app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
parentStable for sparc, wrt bug #506786 (diff)
downloadgentoo-2-4b3de208b2b52b518d8acc7f975efc53523056f6.tar.gz
gentoo-2-4b3de208b2b52b518d8acc7f975efc53523056f6.tar.bz2
gentoo-2-4b3de208b2b52b518d8acc7f975efc53523056f6.zip
[QA] EAPI 1 -> 5. Added missing dev-qt/qtcore:4 dependency.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild b/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
index 500c58a9b3f9..0c8a9e7a4042 100644
--- a/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild,v 1.5 2013/03/02 19:14:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.1.0-r2.ebuild,v 1.6 2014/05/14 14:41:26 tomwij Exp $
-EAPI="1"
+EAPI="5"
inherit eutils
DESCRIPTION="A time-memory-trade-off-cracker"
@@ -16,27 +16,20 @@ IUSE="qt4 debug"
CDEPEND="dev-libs/openssl
net-libs/netwib
- qt4? ( dev-qt/qtgui:4 )"
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )"
DEPEND="app-arch/unzip
virtual/pkgconfig
${CDEPEND}"
RDEPEND="app-crypt/ophcrack-tables
${CDEPEND}"
-src_compile() {
- local myconf
-
- myconf="$(use_enable qt4 gui)"
- myconf="${myconf} $(use_enable debug)"
-
- econf ${myconf} || die "Failed to compile"
- emake || die "Failed to make"
+src_configure() {
+ econf $(use_enable qt4 gui) $(use_enable debug)
}
src_install() {
- emake install DESTDIR="${D}" || die "Installation failed."
+ default
- cd "${S}"
- newicon src/gui/pixmaps/os.xpm ophcrack.xpm
- make_desktop_entry "${PN}" OphCrack ophcrack
+ newicon src/gui/pixmaps/os.xpm ${PN}.xpm
+ make_desktop_entry "${PN}" OphCrack ${PN}
}