summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-24 09:00:35 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-24 09:00:35 +0000
commitc0cabc59cc195d63a8c2aeccdefe7865fcdbba3a (patch)
tree5092d7d44322e55ccefe620dada6602c8711d7a9 /app-crypt/p11-kit
parentVersion bump. (diff)
downloadgentoo-2-c0cabc59cc195d63a8c2aeccdefe7865fcdbba3a.tar.gz
gentoo-2-c0cabc59cc195d63a8c2aeccdefe7865fcdbba3a.tar.bz2
gentoo-2-c0cabc59cc195d63a8c2aeccdefe7865fcdbba3a.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog9
-rw-r--r--app-crypt/p11-kit/p11-kit-0.20.2.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index aa1103c1b028..1e8c7f0c284c 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.51 2013/09/27 07:29:21 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.52 2014/01/24 09:00:35 radhermit Exp $
+
+*p11-kit-0.20.2 (24 Jan 2014)
+
+ 24 Jan 2014; Tim Harder <radhermit@gentoo.org> +p11-kit-0.20.2.ebuild:
+ Version bump.
*p11-kit-0.20.1 (27 Sep 2013)
diff --git a/app-crypt/p11-kit/p11-kit-0.20.2.ebuild b/app-crypt/p11-kit/p11-kit-0.20.2.ebuild
new file mode 100644
index 000000000000..300255437f6e
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.20.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.20.2.ebuild,v 1.1 2014/01/24 09:00:35 radhermit Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}