summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-05-03 15:17:14 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2015-05-03 15:17:14 +0000
commitc9dd77174692900108a0a4c9c413f35833b4aa04 (patch)
tree46f35ee9d4bbf8ec234d5ff93acf031c8721886d /app-crypt/pinentry
parentFix bug 489718. (diff)
downloadgentoo-2-c9dd77174692900108a0a4c9c413f35833b4aa04.tar.gz
gentoo-2-c9dd77174692900108a0a4c9c413f35833b4aa04.tar.bz2
gentoo-2-c9dd77174692900108a0a4c9c413f35833b4aa04.zip
Version bump, bug#548456
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/files/pinentry-0.9.1-memleak.patch26
-rw-r--r--app-crypt/pinentry/pinentry-0.9.1.ebuild91
3 files changed, 124 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 382cb3107ff3..577dd5a62919 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/pinentry
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.168 2015/04/30 19:51:33 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.169 2015/05/03 15:17:14 alonbl Exp $
+
+*pinentry-0.9.1 (03 May 2015)
+
+ 03 May 2015; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/pinentry-0.9.1-memleak.patch, +pinentry-0.9.1.ebuild:
+ Version bump, bug#548456
30 Apr 2015; Alon Bar-Lev <alonbl@gentoo.org> pinentry-0.9.0-r3.ebuild:
Fix gcc-5 qt issue, bug#547528, thanks to Mark Wright
diff --git a/app-crypt/pinentry/files/pinentry-0.9.1-memleak.patch b/app-crypt/pinentry/files/pinentry-0.9.1-memleak.patch
new file mode 100644
index 000000000000..fcdd88b4c3db
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-0.9.1-memleak.patch
@@ -0,0 +1,26 @@
+From 03e4207f11e228a4c079af991f82507539793bae Mon Sep 17 00:00:00 2001
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Tue, 28 Apr 2015 13:01:16 -0400
+Subject: [PATCH] fix small memory leak in pinentry-curses
+
+* pinentry/pinentry-curses.c: free internally allocated local string.
+---
+ pinentry/pinentry-curses.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/pinentry/pinentry-curses.c b/pinentry/pinentry-curses.c
+index 4b7080e..043f8a9 100644
+--- a/pinentry/pinentry-curses.c
++++ b/pinentry/pinentry-curses.c
+@@ -199,6 +199,8 @@ utf8_to_local (char *lc_ctype, char *string)
+ memset (&ps, 0, sizeof(mbstate_t));
+ mbsrtowcs (wcs, &p, len, &ps);
+
++ free (local);
++
+ leave:
+ if (old_ctype)
+ {
+--
+2.1.4
+
diff --git a/app-crypt/pinentry/pinentry-0.9.1.ebuild b/app-crypt/pinentry/pinentry-0.9.1.ebuild
new file mode 100644
index 000000000000..9e682d5ea169
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.9.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.9.1.ebuild,v 1.1 2015/05/03 15:17:14 alonbl Exp $
+
+EAPI=5
+
+inherit qmake-utils autotools multilib eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="clipboard gtk ncurses qt4 caps static"
+
+RDEPEND="
+ app-eselect/eselect-pinentry
+ caps? ( sys-libs/libcap )
+ gtk? ( x11-libs/gtk+:2 )
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( >=dev-qt/qtgui-4.4.1:4 )
+ static? ( >=sys-libs/ncurses-5.7-r5[static-libs,-gpm] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ gtk? ( virtual/pkgconfig )
+ qt4? ( virtual/pkgconfig )
+ ppc-aix? ( dev-libs/gnulib )
+"
+REQUIRED_USE="
+ || ( ncurses gtk qt4 )
+ gtk? ( !static )
+ qt4? ( !static )
+ static? ( ncurses )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
+ epatch "${FILESDIR}/${P}-memleak.patch"
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
+
+ if [[ ${CHOST} == *-aix* ]] ; then
+ append-flags -I"${EPREFIX}/usr/$(get_libdir)/gnulib/include"
+ append-ldflags -L"${EPREFIX}/usr/$(get_libdir)/gnulib/$(get_libdir)"
+ append-libs -lgnu
+ fi
+
+ # Issues finding qt on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+
+ econf \
+ --enable-pinentry-tty \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_enable qt4 pinentry-qt4) \
+ $(use qt4 && use_enable clipboard pinentry-qt4-clipboard) \
+ $(use_with caps libcap) \
+ MOC="$(qt4_get_bindir)"/moc
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/bin/pinentry || die
+}
+
+pkg_postinst() {
+ if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+ fi
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}