summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-08-31 00:56:06 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-08-31 00:56:06 +0000
commit61b4a1b29d2b5354182b193ecfeb2125e02fe3b5 (patch)
tree1c60f2d2c1cd487f028b9c13130f8b5940d8ceda /app-crypt/qca
parentversion bump as per bug #225389 requested by Davide Pesavento (diff)
downloadgentoo-2-61b4a1b29d2b5354182b193ecfeb2125e02fe3b5.tar.gz
gentoo-2-61b4a1b29d2b5354182b193ecfeb2125e02fe3b5.tar.bz2
gentoo-2-61b4a1b29d2b5354182b193ecfeb2125e02fe3b5.zip
version bump as per bug #225467 requested by Davide Pesavento
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog7
-rw-r--r--app-crypt/qca/qca-2.0.1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 9f6241f6010a..96a10d3a1dba 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.42 2008/07/27 19:14:20 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.43 2008/08/31 00:56:06 dragonheart Exp $
+
+*qca-2.0.1 (31 Aug 2008)
+
+ 31 Aug 2008; Daniel Black <dragonheart@gentoo.org> +qca-2.0.1.ebuild:
+ version bump as per bug #225467 requested by Davide Pesavento
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qca-1.0-r2.ebuild,
qca-1.0-r3.ebuild:
diff --git a/app-crypt/qca/qca-2.0.1.ebuild b/app-crypt/qca/qca-2.0.1.ebuild
new file mode 100644
index 000000000000..58d632e52640
--- /dev/null
+++ b/app-crypt/qca/qca-2.0.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.1.ebuild,v 1.1 2008/08/31 00:56:06 dragonheart Exp $
+
+EAPI="1"
+
+inherit eutils multilib qt4
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+RESTRICT="test"
+
+DEPEND="!<app-crypt/qca-1.0-r3
+ || ( x11-libs/qt-core:4
+ >=x11-libs/qt-4.2.0:4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use debug; then
+ if has_version "<x11-libs/qt-4.4.0_alpha1:4" && ! built_with_use x11-libs/qt:4 debug; then
+ eerror "You are trying to compile ${PN} with USE=\"debug\""
+ eerror "while x11-libs/qt:4 is built without this particular flag."
+ die "Rebuild x11-libs/qt:4 with USE=\"debug\"."
+ elif has_version "x11-libs/qt-core:4" && ! built_with_use x11-libs/qt-core:4 debug; then
+ eerror "You are trying to compile ${PN} with USE=\"debug\""
+ eerror "while x11-libs/qt-core:4 is built without this particular flag."
+ die "Rebuild x11-libs/qt-core:4 with USE=\"debug\"."
+ fi
+ fi
+}
+
+src_compile() {
+ _libdir=$(get_libdir)
+ local myconf
+ use debug && myconf="--debug" || myconf="--release"
+
+ ./configure \
+ --prefix=/usr \
+ --qtdir=/usr \
+ --includedir="/usr/include/qca2" \
+ --libdir="/usr/${_libdir}/qca2" \
+ --no-separate-debug-info \
+ --disable-tests \
+ ${myconf} \
+ || die "configure failed"
+
+ eqmake4 ${PN}.pro
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README TODO || die "dodoc failed."
+
+ cat <<-EOF > "${WORKDIR}"/44qca2
+ LDPATH=/usr/${_libdir}/qca2
+ EOF
+ doenvd "${WORKDIR}"/44qca2
+
+ if use doc; then
+ dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r "${S}"/examples || die "Failed to install examples"
+ fi
+}