summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 10:04:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 10:04:01 +0000
commit18869b9188754d98d50c2a35cfadc11181aa6a46 (patch)
treef6ab916c0938ee73a82c3a1a704d83f738926810 /app-crypt/seahorse
parentVersion bump for Gnome 3.16. Clean up old revision. (diff)
downloadgentoo-2-18869b9188754d98d50c2a35cfadc11181aa6a46.tar.gz
gentoo-2-18869b9188754d98d50c2a35cfadc11181aa6a46.tar.bz2
gentoo-2-18869b9188754d98d50c2a35cfadc11181aa6a46.zip
Version bump for Gnome 3.16.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog7
-rw-r--r--app-crypt/seahorse/seahorse-3.16.0.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index bbe530ce8329..7878526d2e5b 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/seahorse
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.192 2015/05/13 16:54:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.193 2015/06/09 10:04:01 eva Exp $
+
+*seahorse-3.16.0 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +seahorse-3.16.0.ebuild:
+ Version bump for Gnome 3.16.
13 May 2015; Pacho Ramos <pacho@gentoo.org> -seahorse-3.12.2.ebuild,
-seahorse-3.14.0.ebuild, seahorse-3.14.1.ebuild:
diff --git a/app-crypt/seahorse/seahorse-3.16.0.ebuild b/app-crypt/seahorse/seahorse-3.16.0.ebuild
new file mode 100644
index 000000000000..2880675dc45a
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.16.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-3.16.0.ebuild,v 1.1 2015/06/09 10:04:01 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="debug ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.11.91:=
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-3.4:3
+ >=app-crypt/libsecret-0.16
+ >=net-libs/libsoup-2.33.92:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-1.4
+ <app-crypt/gnupg-2.1
+
+ ldap? ( net-nds/openldap:= )
+ zeroconf? ( >=net-dns/avahi-0.6:= )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+src_prepare() {
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bindir is needed due to bad macro expansion in desktop file, bug #508610
+ gnome2_src_configure \
+ --bindir=/usr/bin \
+ --enable-pgp \
+ --enable-ssh \
+ --enable-pkcs11 \
+ --enable-hkp \
+ $(use_enable debug) \
+ $(use_enable ldap) \
+ $(use_enable zeroconf sharing) \
+ ITSTOOL=$(type -P true) \
+ VALAC=$(type -P true)
+}