summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-03-23 00:31:22 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-03-23 00:31:22 +0000
commit5435106b456df5a82124b3e13f5dbe90a0f40591 (patch)
tree42ee01d52965b71a50bfa7d0f1b9d94625811e74 /app-crypt/seahorse
parentadd new useflags for seahorse (diff)
downloadgentoo-2-5435106b456df5a82124b3e13f5dbe90a0f40591.tar.gz
gentoo-2-5435106b456df5a82124b3e13f5dbe90a0f40591.tar.bz2
gentoo-2-5435106b456df5a82124b3e13f5dbe90a0f40591.zip
version bump for seahorse! its finally there!
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog8
-rw-r--r--app-crypt/seahorse/files/digest-seahorse-1.03
-rw-r--r--app-crypt/seahorse/files/seahorse-0.9.10-update-mime.patch15
-rw-r--r--app-crypt/seahorse/seahorse-1.0.ebuild100
4 files changed, 125 insertions, 1 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 2f237e689078..bef2e655114a 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/seahorse
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.65 2007/02/16 19:54:16 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.66 2007/03/23 00:31:22 compnerd Exp $
+
+*seahorse-1.0 (23 Mar 2007)
+
+ 23 Mar 2007; <compnerd@gentoo.org>
+ +files/seahorse-0.9.10-update-mime.patch, +seahorse-1.0.ebuild:
+ Version bump from upstream
16 Feb 2007; Saleem Abdulrasool <compnerd@gentoo.org>
-files/seahorse-0.6.3-gpg1.4.patch,
diff --git a/app-crypt/seahorse/files/digest-seahorse-1.0 b/app-crypt/seahorse/files/digest-seahorse-1.0
new file mode 100644
index 000000000000..93cedc31e559
--- /dev/null
+++ b/app-crypt/seahorse/files/digest-seahorse-1.0
@@ -0,0 +1,3 @@
+MD5 7afcb9b40aaa0c232ce8a9e0909fe757 seahorse-1.0.tar.bz2 1871080
+RMD160 21b2500be16c0143cee0d5e696c3241597bce2f2 seahorse-1.0.tar.bz2 1871080
+SHA256 76bcfeed3843b2357f5ecc1694a471fc45a810aa17fd0baed60f1d32142d0746 seahorse-1.0.tar.bz2 1871080
diff --git a/app-crypt/seahorse/files/seahorse-0.9.10-update-mime.patch b/app-crypt/seahorse/files/seahorse-0.9.10-update-mime.patch
new file mode 100644
index 000000000000..5b6300ffd8cc
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.9.10-update-mime.patch
@@ -0,0 +1,15 @@
+--- plugins/nautilus/Makefile.in.orig 2007-01-24 20:37:53.000000000 -0600
++++ plugins/nautilus/Makefile.in 2007-01-24 20:38:06.000000000 -0600
+@@ -786,11 +786,9 @@
+
+
+ @UPDATE_MIME_DATABASE_TRUE@install-data-local:
+-@UPDATE_MIME_DATABASE_TRUE@ mkdir -p $(mimedir)
+-@UPDATE_MIME_DATABASE_TRUE@ update-mime-database $(datadir)/mime/
+
+ @UPDATE_MIME_DATABASE_TRUE@uninstall-local:
+-@UPDATE_MIME_DATABASE_TRUE@ update-mime-database $(datadir)/mime/
++
+ @UPDATE_MIME_DATABASE_FALSE@install-data-local:
+
+ @UPDATE_MIME_DATABASE_FALSE@uninstall-local:
diff --git a/app-crypt/seahorse/seahorse-1.0.ebuild b/app-crypt/seahorse/seahorse-1.0.ebuild
new file mode 100644
index 000000000000..833643a2147b
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-1.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-1.0.ebuild,v 1.1 2007/03/23 00:31:22 compnerd Exp $
+
+inherit gnome2 eutils flag-o-matic
+
+GNOME_TARBALL_SUFFIX="gz"
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi dbus debug gedit gnome keyring ldap libnotify nautilus"
+
+RDEPEND=">=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/gnome-vfs-2.0
+ >=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.10
+ >=net-libs/libsoup-2.2
+ >=dev-libs/libxml2-2.6.0
+ || (
+ =app-crypt/gnupg-1.2*
+ =app-crypt/gnupg-1.4*
+ )
+ >=app-crypt/gpgme-1.1.0
+ net-misc/openssh
+ x11-misc/shared-mime-info
+ avahi? ( >=net-dns/avahi-0.6 )
+ dbus? ( || (
+ >=dev-libs/dbus-glib-0.72
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.60 )
+ )
+ )
+ gedit? ( >=app-editors/gedit-2.16 )
+ gnome? ( >=gnome-base/gnome-panel-2.10 )
+ keyring? ( gnome-base/gnome-keyring )
+ ldap? ( net-nds/openldap )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ nautilus? ( >=gnome-base/nautilus-2.10 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+
+pkg_setup() {
+ if ! use dbus ; then
+ if use gedit ; then
+ einfo
+ einfo "The GEdit plugin requires that you build seahorse with DBUS support."
+ einfo
+ fi
+
+ if use gnome ; then
+ einfo
+ einfo "The panel applet requires that you build seahorse with DBUS support."
+ einfo
+ fi
+
+ einfo "Please add dbus to your USE flags and re-emerge seahorse"
+ eerror "plugins require dbus support"
+ fi
+
+ G2CONF="${G2CONF} --enable-ssh --disable-update-mime-database \
+ --enable-hkp --with-keyserver --enable-agent \
+ --localstatedir=${D}/var/lib/scrollkeeper/ --disable-epiphany \
+ $(use_enable avahi sharing) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable gedit) \
+ $(use_enable gnome applet) \
+ $(use_enable keyring gnome-keyring) \
+ $(use_enable ldap) \
+ $(use_enable libnotify) \
+ $(use_enable nautilus)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch ${FILESDIR}/${PN}-0.9.10-update-mime.patch
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove conflicts with x11-misc/shared-mime-info
+ rm -rf ${D}/usr/share/mime/{application,magic,globs,XMLnamespaces}
+}