summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-17 19:12:26 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-17 19:12:26 +0000
commit8721cd7c8a662b00683278f4a77cbd9dc0d4663d (patch)
tree92cb525316cc492e85d147e8e4ce015bc7225937 /app-crypt/seahorse
parentVersion bump for Gnome 2.32: includes tons of bugfixes and translation update... (diff)
downloadgentoo-2-8721cd7c8a662b00683278f4a77cbd9dc0d4663d.tar.gz
gentoo-2-8721cd7c8a662b00683278f4a77cbd9dc0d4663d.tar.bz2
gentoo-2-8721cd7c8a662b00683278f4a77cbd9dc0d4663d.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.19/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog8
-rw-r--r--app-crypt/seahorse/metadata.xml2
-rw-r--r--app-crypt/seahorse/seahorse-2.32.0.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index b8d1ef8855e6..8d2c938d3469 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/seahorse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.139 2010/10/17 15:26:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.140 2010/10/17 19:12:26 pacho Exp $
+
+*seahorse-2.32.0 (17 Oct 2010)
+
+ 17 Oct 2010; Pacho Ramos <pacho@gentoo.org> +seahorse-2.32.0.ebuild:
+ Version bump for Gnome 2.32: bugfixes and translation updates. Add
+ introspection support.
17 Oct 2010; Raúl Porcel <armin76@gentoo.org> seahorse-2.30.1.ebuild:
alpha/ia64/sparc stable wrt #324077
diff --git a/app-crypt/seahorse/metadata.xml b/app-crypt/seahorse/metadata.xml
index 06955307321c..d5ac32b7394b 100644
--- a/app-crypt/seahorse/metadata.xml
+++ b/app-crypt/seahorse/metadata.xml
@@ -3,6 +3,8 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
+ <flag name="introspection">Use
+ <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
<flag name="ldap">Enable seahorse to manipulate GPG keys on a LDAP server.</flag>
</use>
<longdescription>Seahorse is a Gnome interface for GnuPG. It's main purpose is to be a PGP/GPG Key Manager, though
diff --git a/app-crypt/seahorse/seahorse-2.32.0.ebuild b/app-crypt/seahorse/seahorse-2.32.0.ebuild
new file mode 100644
index 000000000000..923e54a709db
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-2.32.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.32.0.ebuild,v 1.1 2010/10/17 19:12:26 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug doc +introspection ldap libnotify test"
+
+RDEPEND="
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.18:2[introspection?]
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.29.4
+ net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )
+
+ avahi? ( >=net-dns/avahi-0.6 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ ldap? ( net-nds/openldap )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-pgp
+ --enable-ssh
+ --enable-pkcs11
+ --disable-static
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ --enable-hkp
+ $(use_enable avahi sharing)
+ $(use_enable debug)
+ $(use_enable introspection)
+ $(use_enable ldap)
+ $(use_enable libnotify)
+ $(use_enable test tests)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
+ -e 's/-Werror//' \
+ -i configure.in configure || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has app-crypt/seahorse-plugins; then
+ einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
+ einfo "Use that if you want seahorse to manage your terminal SSH keys"
+ fi
+}