summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-09-22 18:20:50 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-09-22 18:20:50 +0000
commit98d9068fc69b7ca64aee19a7dc72065506aea8c1 (patch)
tree80cfbb51d95b5f6af9f48230072ff2d04d895e9f /app-crypt/xca/xca-0.6.4.ebuild
parentStable on ppc wrt bug 189292 (diff)
downloadgentoo-2-98d9068fc69b7ca64aee19a7dc72065506aea8c1.tar.gz
gentoo-2-98d9068fc69b7ca64aee19a7dc72065506aea8c1.tar.bz2
gentoo-2-98d9068fc69b7ca64aee19a7dc72065506aea8c1.zip
Version bump, bug#192938
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-crypt/xca/xca-0.6.4.ebuild')
-rw-r--r--app-crypt/xca/xca-0.6.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/xca/xca-0.6.4.ebuild b/app-crypt/xca/xca-0.6.4.ebuild
new file mode 100644
index 000000000000..499243ad28d9
--- /dev/null
+++ b/app-crypt/xca/xca-0.6.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.6.4.ebuild,v 1.1 2007/09/22 18:20:49 alonbl Exp $
+
+inherit eutils
+
+DESCRIPTION="A graphical user interface to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.8
+ =x11-libs/qt-4*"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+# Upstream:
+# http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+#
+# 1. Qt detection.
+# 2. doc hacks.
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR=/usr \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ prefix=/usr \
+ ./configure || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install || die "install failed"
+
+ dodoc README CREDITS AUTHORS COPYRIGHT
+
+ insinto /etc/xca
+ doins misc/*.txt
+}