summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2014-02-14 22:41:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2014-02-14 22:41:38 +0000
commit04a99cb2bc93d1b91fb6b14f74318ed93c62e232 (patch)
tree3831279f8dcd53ab8f57a6af875029c434a692f0 /app-crypt
parentDrop ChangeLog. (diff)
downloadgentoo-2-04a99cb2bc93d1b91fb6b14f74318ed93c62e232.tar.gz
gentoo-2-04a99cb2bc93d1b91fb6b14f74318ed93c62e232.tar.bz2
gentoo-2-04a99cb2bc93d1b91fb6b14f74318ed93c62e232.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ccid/ChangeLog9
-rw-r--r--app-crypt/ccid/ccid-1.4.15.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/app-crypt/ccid/ChangeLog b/app-crypt/ccid/ChangeLog
index e48e1780e298..a1213f2020ef 100644
--- a/app-crypt/ccid/ChangeLog
+++ b/app-crypt/ccid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ccid
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.100 2013/12/02 21:43:32 flameeyes Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.101 2014/02/14 22:41:38 flameeyes Exp $
+
+*ccid-1.4.15 (14 Feb 2014)
+
+ 14 Feb 2014; Diego E. Pettenò <flameeyes@gentoo.org> +ccid-1.4.15.ebuild:
+ Version bump.
*ccid-1.4.14 (02 Dec 2013)
diff --git a/app-crypt/ccid/ccid-1.4.15.ebuild b/app-crypt/ccid/ccid-1.4.15.ebuild
new file mode 100644
index 000000000000..ff876ef643ea
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.4.15.ebuild,v 1.1 2014/02/14 22:41:38 flameeyes Exp $
+
+EAPI=5
+
+STUPID_NUM="3989"
+
+inherit eutils toolchain-funcs udev autotools-utils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/frs/download.php/file/${STUPID_NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ local myeconfargs=(
+ LEX=:
+ $(use_enable twinserial)
+ $(use_enable usb libusb)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to nolonger use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+ fi
+}