summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-03 22:20:43 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-03 22:20:43 +0000
commit54b2af808ba42821e4b8eacb53ed7ecfbe974c20 (patch)
treea750c21e7b62cc4478090a6b884d55ef1f08fd7f /app-crypt
parentBump to 2.6.19-r4 (diff)
downloadgentoo-2-54b2af808ba42821e4b8eacb53ed7ecfbe974c20.tar.gz
gentoo-2-54b2af808ba42821e4b8eacb53ed7ecfbe974c20.tar.bz2
gentoo-2-54b2af808ba42821e4b8eacb53ed7ecfbe974c20.zip
Added WANT_AUTOMAKE to fix bug #148904, dropped old versions.
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/ChangeLog6
-rw-r--r--app-crypt/heimdal/heimdal-0.7.2-r3.ebuild15
2 files changed, 14 insertions, 7 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 51081eda51fd..03a5f10c58b6 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.114 2006/09/03 20:34:27 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.115 2006/12/03 22:20:43 dev-zero Exp $
+
+ 03 Dec 2006; Tiziano Müller <dev-zero@gentoo.org> -heimdal-0.7.2.ebuild,
+ -heimdal-0.7.2-r2.ebuild, heimdal-0.7.2-r3.ebuild:
+ Added WANT_AUTOMAKE to fix bug #148904, dropped old versions.
04 Sep 2006; Joshua Kinard <kumba@gentoo.org> heimdal-0.7.2-r3.ebuild:
Marked stable on mips.
diff --git a/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild b/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild
index c06c12538cb6..562e3894e8be 100644
--- a/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild
+++ b/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild,v 1.11 2006/09/03 20:34:27 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.2-r3.ebuild,v 1.12 2006/12/03 22:20:43 dev-zero Exp $
+
+WANT_AUTOMAKE=1.8
+WANT_AUTOCONF=latest
inherit autotools libtool eutils virtualx toolchain-funcs
@@ -60,10 +63,10 @@ src_compile() {
--libexecdir=/usr/sbin \
${myconf} || die "econf failed"
- emake || die
+ emake || die "emake failed"
# Compile the added password checker:
- cd ${S}/lib/kadm5
+ cd lib/kadm5
tc-export CC
${CC} -shared -fPIC \
${CFLAGS} -I${S}/include \
@@ -84,9 +87,9 @@ src_test() {
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
- dolib ${S}/lib/kadm5/sample_passwd_check.so
+ dolib lib/kadm5/sample_passwd_check.so
dodoc ChangeLog README NEWS TODO
@@ -124,7 +127,7 @@ src_install() {
insinto /etc
newins ${GENTOODIR}/configs/krb5.conf krb5.conf.example
- sed -i "s:/lib:/$(get_libdir):" ${D}/etc/krb5.conf.example
+ sed -i "s:/lib:/$(get_libdir):" ${D}/etc/krb5.conf.example || die "sed failed"
if use ldap; then
insinto /etc/openldap/schema