summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-03-07 12:44:57 +0000
committerPacho Ramos <pacho@gentoo.org>2015-03-07 12:44:57 +0000
commita8d02cf7901055d964aa5ef5cdec3d9323a6433b (patch)
treee6bffd262782b88b794511b284da4aacc3d1dbab /app-crypt
parentVersion bump (diff)
downloadgentoo-2-a8d02cf7901055d964aa5ef5cdec3d9323a6433b.tar.gz
gentoo-2-a8d02cf7901055d964aa5ef5cdec3d9323a6433b.tar.bz2
gentoo-2-a8d02cf7901055d964aa5ef5cdec3d9323a6433b.zip
Version bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog9
-rw-r--r--app-crypt/seahorse/seahorse-3.14.1.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index e9c8418a383a..433c80d9f90e 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/seahorse
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.188 2014/12/30 11:41:23 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.189 2015/03/07 12:44:57 pacho Exp $
+
+*seahorse-3.14.1 (07 Mar 2015)
+
+ 07 Mar 2015; Pacho Ramos <pacho@gentoo.org> +seahorse-3.14.1.ebuild:
+ Version bump
30 Dec 2014; Pacho Ramos <pacho@gentoo.org> seahorse-3.12.2.ebuild,
seahorse-3.14.0.ebuild:
diff --git a/app-crypt/seahorse/seahorse-3.14.1.ebuild b/app-crypt/seahorse/seahorse-3.14.1.ebuild
new file mode 100644
index 000000000000..864202155671
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.14.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-3.14.1.ebuild,v 1.1 2015/03/07 12:44:57 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="debug ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.11.91:=
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-3.4:3
+ >=app-crypt/libsecret-0.16
+ >=net-libs/libsoup-2.33.92:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-1.4
+
+ ldap? ( net-nds/openldap:= )
+ zeroconf? ( >=net-dns/avahi-0.6:= )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+src_prepare() {
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bindir is needed due to bad macro expansion in desktop file, bug #508610
+ gnome2_src_configure \
+ --bindir=/usr/bin \
+ --enable-pgp \
+ --enable-ssh \
+ --enable-pkcs11 \
+ --enable-hkp \
+ $(use_enable debug) \
+ $(use_enable ldap) \
+ $(use_enable zeroconf sharing) \
+ ITSTOOL=$(type -P true) \
+ VALAC=$(type -P true)
+}