summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-02-20 15:21:58 +0000
committerEray Aslan <eras@gentoo.org>2013-02-20 15:21:58 +0000
commitecb2831b61c74ab7ff67ba05a78efced120a0f83 (patch)
tree85195cb0f2f6204710b07957f3d03d7eccea6709 /app-crypt
parentStable for HPPA (bug #456656). (diff)
downloadgentoo-2-ecb2831b61c74ab7ff67ba05a78efced120a0f83.tar.gz
gentoo-2-ecb2831b61c74ab7ff67ba05a78efced120a0f83.tar.bz2
gentoo-2-ecb2831b61c74ab7ff67ba05a78efced120a0f83.zip
Fix building with dev-libs/libtasn1-3 - bug #440322
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/shishi/ChangeLog9
-rw-r--r--app-crypt/shishi/shishi-1.0.1-r2.ebuild82
2 files changed, 89 insertions, 2 deletions
diff --git a/app-crypt/shishi/ChangeLog b/app-crypt/shishi/ChangeLog
index 9a8df2a83253..4cadd1e72db4 100644
--- a/app-crypt/shishi/ChangeLog
+++ b/app-crypt/shishi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/shishi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/ChangeLog,v 1.6 2012/10/09 08:54:31 eras Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/ChangeLog,v 1.7 2013/02/20 15:21:58 eras Exp $
+
+*shishi-1.0.1-r2 (20 Feb 2013)
+
+ 20 Feb 2013; Eray Aslan <eras@gentoo.org> +shishi-1.0.1-r2.ebuild:
+ Fix building with dev-libs/libtasn1-3 - bug #440322
*shishi-1.0.1-r1 (09 Oct 2012)
diff --git a/app-crypt/shishi/shishi-1.0.1-r2.ebuild b/app-crypt/shishi/shishi-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..db02d2432029
--- /dev/null
+++ b/app-crypt/shishi/shishi-1.0.1-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/shishi-1.0.1-r2.ebuild,v 1.1 2013/02/20 15:21:58 eras Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A free implementation of the Kerberos 5 network security system"
+HOMEPAGE="https://www.gnu.org/software/shishi/"
+SRC_URI="mirror://gnu/shishi/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnutls idn ipv6 nls pam +des +3des +aes +md +null +arcfour static-libs"
+
+DEPEND="gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ dev-libs/libtasn1
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix finding libresolv.so
+ epatch "${FILESDIR}/${PN}_resolv.patch"
+ # fix building with automake-1.12 bug #424095
+ epatch "${FILESDIR}/${PN}_automake-1.12.patch"
+ # fix building with glibc-2.16.0
+ epatch "${FILESDIR}/${PN}_gets.patch"
+
+ # don't create a new database
+ sed -i -e '/install-data-hook/s/^/#/' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DMAX_ERROR_DESCRIPTION_SIZE=ASN1_MAX_ERROR_DESCRIPTION_SIZE
+ econf \
+ $(use_enable pam) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_with idn libidn-prefix) \
+ $(use_enable gnutls starttls) \
+ $(use_enable des) \
+ $(use_enable 3des) \
+ $(use_enable aes) \
+ $(use_enable md) \
+ $(use_enable null) \
+ $(use_enable arcfour) \
+ $(use_enable static-libs static) \
+ --with-system-asn1 \
+ --with-libgcrypt \
+ --with-html-dir=/usr/share/doc/${P} \
+ --with-db-dir=/var/shishi \
+ --with-pam-dir=/$(get_libdir)/security \
+ --disable-rpath \
+ --with-packager="Gentoo" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ keepdir /var/shishi
+ fperms 0700 /var/shishi
+ echo "db file /var/shishi" >> "${D}/etc/shishi/shisa.conf" || die
+
+ newinitd "${FILESDIR}/shishid.init" shishid
+ newconfd "${FILESDIR}/shishid.confd" shishid
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ doman doc/man/* doc/*.1
+ dohtml doc/reference/html/*
+ doinfo doc/*.info*
+
+ rm -f "${D}/$(get_libdir)/security/pam_shishi.la"
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+}