summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-08-13 21:15:02 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-08-13 21:15:02 +0000
commit5d40314959752b63fb66f0190135c4ba9c6ca3cb (patch)
tree22d4fc40ef980af8ddfba462757abcc26b962fc1 /app-dicts
parentupdate SRC_URI to point to mirror://gentoo instead of spyderous's space (Mani... (diff)
downloadgentoo-2-5d40314959752b63fb66f0190135c4ba9c6ca3cb.tar.gz
gentoo-2-5d40314959752b63fb66f0190135c4ba9c6ca3cb.tar.bz2
gentoo-2-5d40314959752b63fb66f0190135c4ba9c6ca3cb.zip
Initial commit. Thanks <roma1390@uosis.mif.vu.lt> for the ebuild. bug #32120
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/opendict/ChangeLog7
-rw-r--r--app-dicts/opendict/Manifest4
-rw-r--r--app-dicts/opendict/files/digest-opendict-0.5.41
-rw-r--r--app-dicts/opendict/metadata.xml5
-rw-r--r--app-dicts/opendict/opendict-0.5.4.ebuild42
5 files changed, 59 insertions, 0 deletions
diff --git a/app-dicts/opendict/ChangeLog b/app-dicts/opendict/ChangeLog
new file mode 100644
index 000000000000..e4c4d2dcc1da
--- /dev/null
+++ b/app-dicts/opendict/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for app-dicts/opendict
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.1 2004/08/13 21:15:02 pythonhead Exp $
+
+ 13 Aug 2004; Rob Cakebread <pythonhead@gentoo.org> :
+ Initial commit. Thanks <roma1390@uosis.mif.vu.lt> for the ebuild. bug #32120
+
diff --git a/app-dicts/opendict/Manifest b/app-dicts/opendict/Manifest
new file mode 100644
index 000000000000..9341f03ff46d
--- /dev/null
+++ b/app-dicts/opendict/Manifest
@@ -0,0 +1,4 @@
+MD5 ad2ee9d25406e9585ca0b858ede3b2bd opendict-0.5.4.ebuild 1222
+MD5 4fca175f747a090fd2b7b8ce22fbc06d metadata.xml 162
+MD5 acda02c44edf6fd99d1d0619eeaadb8e ChangeLog 254
+MD5 ee4c1ac428684b6ea366b2075a5b705e files/digest-opendict-0.5.4 66
diff --git a/app-dicts/opendict/files/digest-opendict-0.5.4 b/app-dicts/opendict/files/digest-opendict-0.5.4
new file mode 100644
index 000000000000..14dd2db76c30
--- /dev/null
+++ b/app-dicts/opendict/files/digest-opendict-0.5.4
@@ -0,0 +1 @@
+MD5 4aeae2325ff1a0fe37e5550e29ca4ec6 OpenDict-0.5.4.tar.gz 136927
diff --git a/app-dicts/opendict/metadata.xml b/app-dicts/opendict/metadata.xml
new file mode 100644
index 000000000000..f1dd0cd20500
--- /dev/null
+++ b/app-dicts/opendict/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>wxwindows</herd>
+</pkgmetadata>
diff --git a/app-dicts/opendict/opendict-0.5.4.ebuild b/app-dicts/opendict/opendict-0.5.4.ebuild
new file mode 100644
index 000000000000..362976cdc04f
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.5.4.ebuild,v 1.1 2004/08/13 21:15:02 pythonhead Exp $
+
+inherit python
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program."
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opendict/OpenDict-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-python/wxpython-2.4.2.4
+ virtual/python"
+S=${WORKDIR}/OpenDict-${PV}
+
+src_unpack() {
+ python_version
+ unpack ${A}
+ cd ${S}
+ DHOME="/usr/lib/python${PYVER}/site-packages/opendict"
+ sed -i "s:/usr/share/opendict:${DHOME}:" lib/info.py || die "sed failed"
+ rm Makefile
+}
+
+src_install() {
+ python_version
+ DHOME="${D}/usr/lib/python${PYVER}/site-packages/opendict"
+ dodir /usr/share/locale/lt/LC_MESSAGES
+ dodir /usr/share/applications
+ mkdir -p ${DHOME}
+ cp -r lib/* ${DHOME}
+ cp -r pixmaps/ ${DHOME}
+ cp po/lt/opendict.mo ${D}/usr/share/locale/lt/LC_MESSAGES/
+ cp opendict.py ${DHOME}
+ cp copying.txt ${DHOME}
+ dosym ${DHOME}/opendict.py /usr/bin/opendict
+ cp misc/opendict.desktop ${D}/usr/share/applications/
+ dodoc BUGS ChangeLog README.txt TODO.txt doc/OpenDict_plugin_dev.txt
+}
+