summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-11-24 13:16:40 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-11-24 13:16:40 +0000
commit41bc0ee06ccb34de974d0a50c0cfe2b9d7c29e81 (patch)
tree65c9dd717f062eeddb0eeca2d5ec916e91ba98a9 /app-doc/chmlib
parentStable on sparc wrt #112842 (diff)
downloadgentoo-2-41bc0ee06ccb34de974d0a50c0cfe2b9d7c29e81.tar.gz
gentoo-2-41bc0ee06ccb34de974d0a50c0cfe2b9d7c29e81.tar.bz2
gentoo-2-41bc0ee06ccb34de974d0a50c0cfe2b9d7c29e81.zip
minor adjustment to move compilation into src_compile
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-doc/chmlib')
-rw-r--r--app-doc/chmlib/ChangeLog7
-rw-r--r--app-doc/chmlib/Manifest12
-rw-r--r--app-doc/chmlib/chmlib-0.35-r1.ebuild63
-rw-r--r--app-doc/chmlib/files/digest-chmlib-0.35-r11
4 files changed, 72 insertions, 11 deletions
diff --git a/app-doc/chmlib/ChangeLog b/app-doc/chmlib/ChangeLog
index 423b32205452..3951df44aa6a 100644
--- a/app-doc/chmlib/ChangeLog
+++ b/app-doc/chmlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/chmlib
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/chmlib/ChangeLog,v 1.11 2005/06/24 18:55:13 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/chmlib/ChangeLog,v 1.12 2005/11/24 13:16:40 taviso Exp $
+
+*chmlib-0.35-r1 (24 Nov 2005)
+
+ 24 Nov 2005; Tavis Ormandy <taviso@gentoo.org> +chmlib-0.35-r1.ebuild:
+ minor adjustment to move compilation into src_compile, rather then src_install.
24 Jun 2005; Herbie Hopkins <herbs@gentoo.org> chmlib-0.35.ebuild:
Fixed multilib-strict issue, bug #96958
diff --git a/app-doc/chmlib/Manifest b/app-doc/chmlib/Manifest
index a1229f313a3a..555585a56fa5 100644
--- a/app-doc/chmlib/Manifest
+++ b/app-doc/chmlib/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 2095c8fbff91172458e40a3c7f4c35c4 chmlib-0.32.ebuild 1676
MD5 f30eb2324e15841bcb8d7596bcab1df1 chmlib-0.31.ebuild 1473
MD5 7912dfce57aa45cc73b72fb4c81d5e27 chmlib-0.33.ebuild 1676
+MD5 84850e0b66fadbe8ecb2bfc89b8c23b1 chmlib-0.35-r1.ebuild 1722
MD5 fa6c5694a640524a7ae25445fe5ce11f ChangeLog 1396
MD5 a5f4a4a8acdf2c295bdb3bc50b4e0d86 metadata.xml 254
MD5 3841b3d02541fc293ef1f6a1b42925b5 chmlib-0.35.ebuild 1783
+MD5 5f72df9f154b0843fcc8986396d9e476 files/digest-chmlib-0.35-r1 60
MD5 5e241d7b61c20016a54f95cc7538c41c files/digest-chmlib-0.31 59
MD5 79e2ad3061c14b4285f578bc09190b55 files/digest-chmlib-0.32 60
MD5 d946aa58575a98474e1d1f8c01195a6e files/digest-chmlib-0.33 60
MD5 5f72df9f154b0843fcc8986396d9e476 files/digest-chmlib-0.35 60
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCvFc62G5bA0cA/ScRAoiEAKDBqHkqH7uvK0lDrB4fc2R8aGAgdQCfRD3b
-13r2BluzYqHLtODlfZ0Trf0=
-=g8an
------END PGP SIGNATURE-----
diff --git a/app-doc/chmlib/chmlib-0.35-r1.ebuild b/app-doc/chmlib/chmlib-0.35-r1.ebuild
new file mode 100644
index 000000000000..b195a217b4f2
--- /dev/null
+++ b/app-doc/chmlib/chmlib-0.35-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/chmlib/chmlib-0.35-r1.ebuild,v 1.1 2005/11/24 13:16:40 taviso Exp $
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Library for MS CHM (compressed html) file format plus extracting and http server utils"
+HOMEPAGE="http://66.93.236.84/~jedwin/projects/chmlib/"
+SRC_URI="http://66.93.236.84/~jedwin/projects/chmlib/${P}.tgz"
+DEPEND=">=sys-apps/sed-4"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -r "s,(\\\$\\{INSTALLPREFIX\\}),\${DESTDIR}\\1,g;
+ s,@LIBTOOL@,libtool,g;
+ s,(\\\$\\{INSTALLPREFIX\\})/lib,\1/$(get_libdir),g" \
+ Makefile.in || die "sed failed"
+# sed -i "s:gcc-3.2:gcc:" Makefile
+# sed -i "s:/usr/local/:/${D}/usr/:" Makefile
+ if [ "${ARCH}" = "ppc" ]; then
+ # In this case it is safe to take this rather
+ # stupid action =)
+ sed -i "s:__i386__:__powerpc__:" src/chm_lib.c
+ fi
+ if [ "${ARCH}" == "amd64" ]; then
+ sed -i "s:__i386__:__x86_64__:" src/chm_lib.c
+ fi
+}
+
+src_compile() {
+ append-flags "-L${S}/src/.libs"
+
+ econf || die "econf failed"
+
+ # Build additional utils, making this lib useful by itself.
+ emake all chm_http extract_chmLib || die
+}
+
+src_install() {
+ #Make expects to find these dirs.
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)
+ dodir /usr/include
+ dodir /usr/share/doc/${PF}/examples/
+
+ make install DESTDIR=${D}
+
+ exeinto /usr/bin
+ newexe extract_chmLib chmextract
+ newexe chm_http chmhttp
+
+ #Install examples as well.
+ insinto /usr/share/doc/${PF}/examples/
+ doins src/test_chmLib.c src/enum_chmLib.c src/chm_http.c
+
+ dodoc AUTHORS NEWS README
+}
diff --git a/app-doc/chmlib/files/digest-chmlib-0.35-r1 b/app-doc/chmlib/files/digest-chmlib-0.35-r1
new file mode 100644
index 000000000000..eae8d29031fc
--- /dev/null
+++ b/app-doc/chmlib/files/digest-chmlib-0.35-r1
@@ -0,0 +1 @@
+MD5 8fa0e692b2606a03fb51589f66a82eec chmlib-0.35.tgz 368428