summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-05 17:18:35 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-05 17:18:35 +0000
commit032d938068d7f15c2b2a2c643c3efdb5ad6b9cda (patch)
tree71ca5c3b13ce002aa3c7573b4c0d440a66636376 /app-doc/doxygen
parent$A cleanup; sandbox fixes; header updates (diff)
downloadgentoo-2-032d938068d7f15c2b2a2c643c3efdb5ad6b9cda.tar.gz
gentoo-2-032d938068d7f15c2b2a2c643c3efdb5ad6b9cda.tar.bz2
gentoo-2-032d938068d7f15c2b2a2c643c3efdb5ad6b9cda.zip
new version (user submission <- tvon), includes a patch to compile on a system where both qt2 and qt3
are installed.
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/doxygen-1.2.13.1.ebuild38
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.2.13.11
-rw-r--r--app-doc/doxygen/files/doxygen-1.2.13.1-gentoo.diff11
3 files changed, 50 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.2.13.1.ebuild b/app-doc/doxygen/doxygen-1.2.13.1.ebuild
new file mode 100644
index 000000000000..1f4d56ef5a97
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.2.13.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2001-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Sean Mitchell <sean@arawak.on.ca>, updated Tom von Schwerdtner <tvon@etria.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.2.13.1.ebuild,v 1.1 2002/01/05 17:18:34 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Doxygen is a documentation system for C++, Java, IDL (Corba, Microsoft and KDE-DCOP flavors) and C"
+
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+HOMEPAGE="http://www.doxygen.org"
+
+DEPEND="qt? ( >=x11-libs/qt-2.2.1 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/addon/doxywizard
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+
+}
+
+src_compile()
+{
+
+ use qt && CONFIGURE_OPTIONS="--with-doxywizard"
+
+ QTDIR=/usr/qt/2 ./configure --install install --prefix ${D}/usr ${CONFIGURE_OPTIONS} || die
+ make all || die
+
+}
+
+src_install()
+{
+
+ make install || die
+ dodoc README VERSION LICENSE LANGUAGE.HOWTO PLATFORMS
+
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.2.13.1 b/app-doc/doxygen/files/digest-doxygen-1.2.13.1
new file mode 100644
index 000000000000..3a35a073e414
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.2.13.1
@@ -0,0 +1 @@
+MD5 2fbbf4f0ba6c419c0954c195179f1c0f doxygen-1.2.13.1.src.tar.gz 1794048
diff --git a/app-doc/doxygen/files/doxygen-1.2.13.1-gentoo.diff b/app-doc/doxygen/files/doxygen-1.2.13.1-gentoo.diff
new file mode 100644
index 000000000000..2f358ae411da
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.2.13.1-gentoo.diff
@@ -0,0 +1,11 @@
+--- Makefile.doxywizard Sat Jan 5 19:04:28 2002
++++ Makefile.doxywizard Sat Jan 5 19:05:20 2002
+@@ -25,7 +25,7 @@
+ LINK = g++
+ LFLAGS =
+ LIBS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -lXext -lX11 -lm
+-MOC = moc
++MOC = $(QTDIR)/bin/moc
+
+ TAR = tar -cf
+ GZIP = gzip -9f