summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-07-14 10:27:49 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-07-14 10:27:49 +0000
commit741f58ebd3b924a35cafa525111321a2007e7dc2 (patch)
treef438b430aca05bdf71e6fa794496622db356662d /app-doc/doxygen
parentVersion bump as requested in bug 24292 (diff)
downloadgentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.tar.gz
gentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.tar.bz2
gentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.zip
Version bump as requested in bug 24292
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog7
-rw-r--r--app-doc/doxygen/Manifest4
-rw-r--r--app-doc/doxygen/doxygen-1.3.2.ebuild69
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.3.21
4 files changed, 78 insertions, 3 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 7ec3f650e8c4..e26d31fc881d 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.15 2003/07/01 09:58:46 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.16 2003/07/14 10:27:38 phosphan Exp $
+
+*doxygen-1.3.2 (14 Jul 2003)
+
+ 14 Jul 2003; Patrick Kursawe <phosphan@gentoo.org> doxygen-1.3.2.ebuild:
+ Version bump as requested in bug 24292
01 Jul 2003; Patrick Kursawe <phosphan@gentoo.org> doxygen-1.3.ebuild:
Bug was not yet dead, had to add one more "addwrite" line
diff --git a/app-doc/doxygen/Manifest b/app-doc/doxygen/Manifest
index ebf0610cbdec..5c0fd70c9a9a 100644
--- a/app-doc/doxygen/Manifest
+++ b/app-doc/doxygen/Manifest
@@ -1,9 +1,9 @@
MD5 7c7f9ba848f29b198a01a3eef6801445 doxygen-1.2.15-r1.ebuild 948
MD5 5a1d4e4168eaece67c9a858224bfedfc doxygen-1.3.ebuild 2124
-MD5 4a3cb6f4ccc42ec25f86eb98a76f7bcf doxygen-1.3.2.ebuild 2133
+MD5 e3130a6effe8f29a3c1206541d302b6c doxygen-1.3.2.ebuild 2127
MD5 214d2ce2bfe63e432a6959eb71409e06 doxygen-1.2.16.ebuild 954
MD5 266a0e816968b827296bcbeb80c53333 doxygen-1.2.18.ebuild 1267
-MD5 619a8b86e84e292c5f8ff0d3334be695 ChangeLog 3613
+MD5 d08168977f0c5f256a235e0d03df2415 ChangeLog 3760
MD5 92e72d97f936f9a548b20e2e20e3e385 files/digest-doxygen-1.2.15-r1 71
MD5 17d3c60cd075b3eff3cbe4a5bf00b81c files/doxygen-1.2.16-gentoo.diff 271
MD5 b930ec9ff54b96c72eacc864e989d25e files/digest-doxygen-1.3.2 70
diff --git a/app-doc/doxygen/doxygen-1.3.2.ebuild b/app-doc/doxygen/doxygen-1.3.2.ebuild
new file mode 100644
index 000000000000..3a2a2cd501e3
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.3.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.3.2.ebuild,v 1.1 2003/07/14 10:27:38 phosphan Exp $
+
+IUSE="doc qt"
+
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, IDL (Corba, Microsoft, and KDE-DCOP flavors) and to some extent PHP and C#."
+HOMEPAGE="http://www.doxygen.org"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="media-gfx/graphviz
+ doc? ( app-text/tetex )
+ qt? ( x11-libs/qt )"
+
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS and CXXFLAGS
+ sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
+ -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
+ tmake/lib/linux-g++/tmake.conf
+ # fix doxygen_manual.tex to work with latex-2.x
+ sed -i.orig "s:^\\\setlength\({\\\footrulewidth}\):\\\renewcommand\1:" \
+ doc/doxygen_manual.tex
+ # fix configure to work w/ install from either fileutils or coreutils
+ sed -ie "s/grep fileutils/egrep 'fileutils|coreutils'/" ${S}/configure
+}
+
+src_compile() {
+ # set ./configure options (prefix, Qt based wizard, static)
+ local confopts="--prefix ${D}/usr"
+ use qt && confopts="${confopts} --with-doxywizard"
+ #use static && confopts="${confopts} --static"
+
+ # ./configure and compile
+ ./configure ${confopts} || die '"./configure" failed.'
+ emake all || die '"emake all" failed.'
+
+ # generate html and pdf documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make docs" failed.'
+ fi
+}
+
+src_install() {
+ make install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins latex/doxygen_manual.pdf
+ dohtml -r html/*
+ fi
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.3.2 b/app-doc/doxygen/files/digest-doxygen-1.3.2
new file mode 100644
index 000000000000..bfacd44efd62
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.3.2
@@ -0,0 +1 @@
+MD5 d331ae38761ef9d8ce9f51988f01dcb8 doxygen-1.3.2.src.tar.gz 2269441