summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-05-15 19:42:43 +0000
committerDan Armak <danarmak@gentoo.org>2002-05-15 19:42:43 +0000
commit91c53a49c66918dcb68ae7ef71e6914cbd09a21f (patch)
tree035cf38ac99482c0d7649e30f5c162fbf5251892 /app-doc/qt-docs/qt-docs-3.0.4.1.ebuild
parentmask qt-docs-3.0.4.1 (diff)
downloadgentoo-2-91c53a49c66918dcb68ae7ef71e6914cbd09a21f.tar.gz
gentoo-2-91c53a49c66918dcb68ae7ef71e6914cbd09a21f.tar.bz2
gentoo-2-91c53a49c66918dcb68ae7ef71e6914cbd09a21f.zip
new versionnew version (masked)
Diffstat (limited to 'app-doc/qt-docs/qt-docs-3.0.4.1.ebuild')
-rw-r--r--app-doc/qt-docs/qt-docs-3.0.4.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-doc/qt-docs/qt-docs-3.0.4.1.ebuild b/app-doc/qt-docs/qt-docs-3.0.4.1.ebuild
new file mode 100644
index 000000000000..1593c8348d19
--- /dev/null
+++ b/app-doc/qt-docs/qt-docs-3.0.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/qt-docs/qt-docs-3.0.4.1.ebuild,v 1.1 2002/05/15 19:42:43 danarmak Exp $
+
+# qt-copy-3.0.4 (released with kde-3.0.1)
+
+PV=3.0.4
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+
+S=${WORKDIR}/qt-copy-3.0.4
+
+SRC_URI="ftp://ftp.kde.org/pub/kde/stable/3.0.1/src/qt-copy-${PV}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="=x11-libs/qt-3*"
+RDEPEND="$DEPEND sys-devel/gcc"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_compile() {
+
+ einfo "Nothing to compile."
+
+}
+
+src_install() {
+
+ cd ${S}
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/45qt-docs3
+
+ # docs
+ cd ${S}/doc
+ dodir ${QTBASE}/doc
+ for x in html flyers; do
+ cp -r $x ${D}/${QTBASE}/doc
+ done
+
+ # manpages
+ cp -r ${S}/doc/man ${D}/${QTBASE}
+
+ # examples
+ cp -r ${S}/examples ${D}/${QTBASE}
+
+ # tutorials
+ cp -r ${S}/tutorial ${D}/${QTBASE}
+
+}
+
+