summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-08-23 12:33:28 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-08-23 12:33:28 +0000
commit4851646b5c6433f3bfa3b9e6bcaf309cc5995ab5 (patch)
treef8cde06882dd39d7818bb7bdff9cb606f4d5177f /app-editors/aee
parentupdate to EAPI 4. (diff)
downloadgentoo-2-4851646b5c6433f3bfa3b9e6bcaf309cc5995ab5.tar.gz
gentoo-2-4851646b5c6433f3bfa3b9e6bcaf309cc5995ab5.tar.bz2
gentoo-2-4851646b5c6433f3bfa3b9e6bcaf309cc5995ab5.zip
update to EAPI 4.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'app-editors/aee')
-rw-r--r--app-editors/aee/ChangeLog6
-rw-r--r--app-editors/aee/aee-2.2.15b.ebuild31
-rw-r--r--app-editors/aee/files/aee-ae-location.diff6
3 files changed, 15 insertions, 28 deletions
diff --git a/app-editors/aee/ChangeLog b/app-editors/aee/ChangeLog
index 464aae4a7ff5..04455e756391 100644
--- a/app-editors/aee/ChangeLog
+++ b/app-editors/aee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/aee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/ChangeLog,v 1.2 2011/06/30 12:55:40 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/ChangeLog,v 1.3 2011/08/23 12:33:28 hattya Exp $
+
+ 23 Aug 2011; Akinori Hattori <hattya@gentoo.org> aee-2.2.15b.ebuild,
+ files/aee-ae-location.diff:
+ update to EAPI 4.
30 Jun 2011; Akinori Hattori <hattya@gentoo.org> aee-2.2.15b.ebuild:
stable on x86 and add ~amd64. fixes bug #372579.
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
index eee6aae4eadb..15989f9dfed7 100644
--- a/app-editors/aee/aee-2.2.15b.ebuild
+++ b/app-editors/aee/aee-2.2.15b.ebuild
@@ -1,57 +1,47 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/aee-2.2.15b.ebuild,v 1.2 2011/06/30 12:55:40 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/aee/aee-2.2.15b.ebuild,v 1.3 2011/08/23 12:33:28 hattya Exp $
-EAPI="3"
+EAPI="4"
inherit eutils toolchain-funcs
-IUSE="X"
-
DESCRIPTION="An easy to use text editor."
HOMEPAGE="http://mahon.cwx.net/"
SRC_URI="http://mahon.cwx.net/sources/${P}.tar.gz"
LICENSE="Artistic"
-KEYWORDS="~amd64 x86"
SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="X"
-DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
src_prepare() {
-
epatch "${FILESDIR}"/${PN}-*.diff
sed -i \
-e "s/make -/\$(MAKE) -/g" \
-e "/^buildaee/s/$/ localaee/" \
-e "/^buildxae/s/$/ localxae/" \
- Makefile \
- || die
+ Makefile
sed -i \
-e "s/\([\t ]\)cc /\1\\\\\$(CC) /" \
-e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
-e "/other_cflag/s/ \${strip_option}//" \
- create.mk.{aee,xae} \
- || die
-
+ create.mk.{aee,xae}
}
src_compile() {
-
local target="aee"
+ use X && target="both"
- if use X; then
- target="both"
- fi
-
- emake ${target} || die
-
+ emake ${target}
}
src_install() {
-
dobin aee
dosym aee /usr/bin/rae
doman aee.1
@@ -64,5 +54,4 @@ src_install() {
dobin xae
dosym xae /usr/bin/rxae
fi
-
}
diff --git a/app-editors/aee/files/aee-ae-location.diff b/app-editors/aee/files/aee-ae-location.diff
index 86022005cb50..9bc6cd5421c0 100644
--- a/app-editors/aee/files/aee-ae-location.diff
+++ b/app-editors/aee/files/aee-ae-location.diff
@@ -1,4 +1,3 @@
-diff -u aee-2.2.15b.orig/aee.1 aee-2.2.15b/aee.1
--- aee-2.2.15b.orig/aee.1
+++ aee-2.2.15b/aee.1
@@ -678,7 +678,7 @@
@@ -28,7 +27,6 @@ diff -u aee-2.2.15b.orig/aee.1 aee-2.2.15b/aee.1
.br
.I $HOME/.aeeinfo
.br
-diff -u aee-2.2.15b.orig/aee.c aee-2.2.15b/aee.c
--- aee-2.2.15b.orig/aee.c
+++ aee-2.2.15b/aee.c
@@ -2612,7 +2612,7 @@
@@ -40,7 +38,6 @@ diff -u aee-2.2.15b.orig/aee.c aee-2.2.15b/aee.c
NULL,
".init.ae"
};
-diff -u aee-2.2.15b.orig/aee.msg aee-2.2.15b/aee.msg
--- aee-2.2.15b.orig/aee.msg
+++ aee-2.2.15b/aee.msg
@@ -2,7 +2,7 @@
@@ -52,7 +49,6 @@ diff -u aee-2.2.15b.orig/aee.msg aee-2.2.15b/aee.msg
2 "main"
3 "modes menu"
4 "tabs to spaces "
-diff -u aee-2.2.15b.orig/help.ae aee-2.2.15b/help.ae
--- aee-2.2.15b.orig/help.ae
+++ aee-2.2.15b/help.ae
@@ -1058,11 +1058,11 @@
@@ -69,7 +65,6 @@ diff -u aee-2.2.15b.orig/help.ae aee-2.2.15b/help.ae
.init.ae, then the current directory. The settings from each file are read,
so that the directives from the most recently read file will take precedence
over previously read files. This allows, for example, the .init.ae file in
-diff -u aee-2.2.15b.orig/help.c aee-2.2.15b/help.c
--- aee-2.2.15b.orig/help.c
+++ aee-2.2.15b/help.c
@@ -12,7 +12,7 @@
@@ -81,7 +76,6 @@ diff -u aee-2.2.15b.orig/help.c aee-2.2.15b/help.c
"~/.help.ae",
"help.ae"
};
-diff -u aee-2.2.15b.orig/localize.c aee-2.2.15b/localize.c
--- aee-2.2.15b.orig/localize.c
+++ aee-2.2.15b/localize.c
@@ -64,7 +64,7 @@