summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-09-22 18:21:06 +0000
committerHanno Böck <hanno@gentoo.org>2005-09-22 18:21:06 +0000
commitcfbde9b44303c058aade1926d696da6a44cccc56 (patch)
treea89ca9721a8e652ffee8af3ad7109f0aaacf2533 /app-editors/bluefish/bluefish-1.0.4.ebuild
parentBump to 3.5 beta1. (diff)
downloadgentoo-2-cfbde9b44303c058aade1926d696da6a44cccc56.tar.gz
gentoo-2-cfbde9b44303c058aade1926d696da6a44cccc56.tar.bz2
gentoo-2-cfbde9b44303c058aade1926d696da6a44cccc56.zip
bluefish version bump
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-editors/bluefish/bluefish-1.0.4.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-1.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-1.0.4.ebuild b/app-editors/bluefish/bluefish-1.0.4.ebuild
new file mode 100644
index 000000000000..5f152ed8807d
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.4.ebuild,v 1.1 2005/09/22 18:21:06 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --disable-update-databases \
+ `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ update-mime-database /usr/share/mime
+}