summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-11-17 18:49:57 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-11-17 18:49:57 +0000
commitba121462560c90672d54804e08261a5c8b652448 (patch)
treed3f8b596e838127420b65adbb8449c622a7d9ca7 /app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch
parentInitial import, thanks to Didier Barvaux (bug #293288) (diff)
downloadgentoo-2-ba121462560c90672d54804e08261a5c8b652448.tar.gz
gentoo-2-ba121462560c90672d54804e08261a5c8b652448.tar.bz2
gentoo-2-ba121462560c90672d54804e08261a5c8b652448.zip
Version bump. Added a dirty patch which fixes automagic installation of the charmap plugin.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch')
-rw-r--r--app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch b/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch
new file mode 100644
index 000000000000..2d286ad30a68
--- /dev/null
+++ b/app-editors/bluefish/files/bluefish-1.3.8-gucharmap-automagic.patch
@@ -0,0 +1,60 @@
+--- configure.ac.old 2009-11-16 22:05:28.000000000 +0100
++++ configure.ac 2009-11-16 23:46:49.000000000 +0100
+@@ -415,29 +415,38 @@
+
+ PKG_CHECK_MODULES([BLUEFISH_REQUIRED], [$BF_dependencies])
+
+-# optionally build the charmap plugin if gucharmap is available
+-PKG_CHECK_MODULES(
+- [CHARMAP_PLUGIN],
+- [gucharmap-2],
+- [
+- build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+- ],
+- [PKG_CHECK_MODULES(
++# build the charmap plugin
++
++AC_ARG_ENABLE(
++ [charmap],
++ AC_HELP_STRING(
++ [--enable-charmap],
++ [enable (or disable) the charmap plugin needs gucharmap @<:@default=no@:>@]
++ )
++)
++
++if test "x$enable_charmap" != "xno"; then
++ PKG_CHECK_MODULES(
+ [CHARMAP_PLUGIN],
+- [gucharmap >= 2.20],
++ [gucharmap-2],
+ [
+ build_charmap_plugin=yes
+- AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ AC_DEFINE([HAVE_LIBGUCHARMAP_2], [1], [Define to 1 if you have the `gucharmap-2' library (-lgucharmap).])
+ ],
+- [
+- build_charmap_plugin=no
+- AC_MSG_WARN([Disabling the building of the charmap plugin.])
+- AC_MSG_WARN([Install gucharmap/gucharmap2 (>= 2.20) library/headers to build the plugin.])
+- ]
+- )]
+-)
+-AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++ [PKG_CHECK_MODULES(
++ [CHARMAP_PLUGIN],
++ [gucharmap >= 2.20],
++ [
++ build_charmap_plugin=yes
++ AC_DEFINE([HAVE_LIBGUCHARMAP], [1], [Define to 1 if you have the `gucharmap' library (-lgucharmap).])
++ ],
++ )]
++ )
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xyes"])
++else
++ AM_CONDITIONAL([ENABLE_CHARMAP_PLUGIN], [test "x$build_charmap_plugin" = "xno"])
++ AC_MSG_NOTICE([Disable building charmap plugin.])
++fi
+
+ AC_SEARCH_LIBS([nanosleep], [posix4 rt])
+