summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 18:29:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 18:29:29 +0000
commit572c90438ea157cbb871bad27c1cf92342e1bf2c (patch)
treed89b1014db2e40e3f87e9e81c09c312d64a4c920 /app-editors/elvis
parentfixed bug 266532 and adjusted dependencies (diff)
downloadgentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.tar.gz
gentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.tar.bz2
gentoo-2-572c90438ea157cbb871bad27c1cf92342e1bf2c.zip
Fix building with GLIBC 2.10+ wrt #277559.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/ChangeLog8
-rw-r--r--app-editors/elvis/elvis-2.2.0-r3.ebuild12
-rw-r--r--app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch48
3 files changed, 60 insertions, 8 deletions
diff --git a/app-editors/elvis/ChangeLog b/app-editors/elvis/ChangeLog
index d4364daac5bc..6a08b58d1bc4 100644
--- a/app-editors/elvis/ChangeLog
+++ b/app-editors/elvis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/elvis
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.41 2008/03/11 11:24:56 nelchael Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.42 2009/08/05 18:29:29 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> elvis-2.2.0-r3.ebuild,
+ +files/elvis-2.2.0-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #277559.
11 Mar 2008; Krzysiek Pawlik <nelchael@gentoo.org> -elvis-2.2.0-r1.ebuild,
-elvis-2.2.0-r2.ebuild, elvis-2.2.0-r3.ebuild:
diff --git a/app-editors/elvis/elvis-2.2.0-r3.ebuild b/app-editors/elvis/elvis-2.2.0-r3.ebuild
index e3cdd0416b3e..5f779ecefed9 100644
--- a/app-editors/elvis/elvis-2.2.0-r3.ebuild
+++ b/app-editors/elvis/elvis-2.2.0-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r3.ebuild,v 1.10 2008/03/11 11:24:56 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r3.ebuild,v 1.11 2009/08/05 18:29:29 ssuominen Exp $
inherit eutils versionator
-MY_PV="$(replace_version_separator 2 '_')"
+MY_PV=$(replace_version_separator 2 '_')
DESCRIPTION="A vi/ex clone"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
@@ -23,13 +23,13 @@ DEPEND=">=sys-libs/ncurses-5.2
>=x11-libs/libXft-2.1.8.2 )
app-admin/eselect-vi"
-S="${WORKDIR}/${PN}-${MY_PV}"
+S=${WORKDIR}/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}/ft2.3-symbol-collision-fix.patch"
+ epatch "${FILESDIR}"/ft2.3-symbol-collision-fix.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
}
src_compile() {
diff --git a/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch b/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..1a3d1affb303
--- /dev/null
+++ b/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
@@ -0,0 +1,48 @@
+diff -ur elvis-2.2_0.orig/ref.c elvis-2.2_0/ref.c
+--- elvis-2.2_0.orig/ref.c 2003-10-21 05:32:25.000000000 +0300
++++ elvis-2.2_0/ref.c 2009-08-05 21:28:30.000000000 +0300
+@@ -42,7 +42,7 @@
+
+ #if USE_PROTOTYPES
+ static void usage(char *argv0);
+-static char *getline(FILE *fp);
++static char *get_line(FILE *fp);
+ static void store(char *line, char **list);
+ static LINECLS classify(char *line, LINECLS prev);
+ static void lookup(TAG *tag);
+@@ -171,7 +171,7 @@
+ /* This function reads a single line, and replaces the terminating newline with
+ * a '\0' byte. The string will be in a static buffer. Returns NULL at EOF.
+ */
+-static char *getline(fp)
++static char *get_line(fp)
+ FILE *fp;
+ {
+ int ch;
+@@ -348,7 +348,7 @@
+ }
+
+ /* for each line... */
+- for (lnum = 1, lc = LC_COMPLETE; (line = getline(fp)) != NULL; lnum++)
++ for (lnum = 1, lc = LC_COMPLETE; (line = get_line(fp)) != NULL; lnum++)
+ {
+ /* is this the tag definition? */
+ if (taglnum > 0 ? taglnum == lnum : !strncmp(tagline, line, len))
+@@ -377,7 +377,7 @@
+ {
+ if (strchr(line, '(') != NULL)
+ {
+- while ((line = getline(fp)) != NULL
++ while ((line = get_line(fp)) != NULL
+ && *line
+ && ((*line != '#' && *line != '{')
+ || line[strlen(line) - 1] == '\\'))
+@@ -387,7 +387,7 @@
+ }
+ else if ((lc = classify(line, lc)) == LC_PARTIAL)
+ {
+- while ((line = getline(fp)) != NULL
++ while ((line = get_line(fp)) != NULL
+ && (lc = classify(line, lc)) == LC_PARTIAL)
+ {
+ puts(line);