summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-22 20:35:57 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-22 20:35:57 +0000
commit9fb49186589497a516c8457cd0be07a56444320b (patch)
treedd0b9be81a08346cc919058d1795f888a8d3ee5d /app-editors/emacs-vcs
parentVersion bump. (diff)
downloadgentoo-2-9fb49186589497a516c8457cd0be07a56444320b.tar.gz
gentoo-2-9fb49186589497a516c8457cd0be07a56444320b.tar.bz2
gentoo-2-9fb49186589497a516c8457cd0be07a56444320b.zip
Add messages to "die" commands.
(Portage version: 2.2_rc85/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs-vcs')
-rw-r--r--app-editors/emacs-vcs/ChangeLog5
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild26
2 files changed, 17 insertions, 14 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index 47dbd806979d..93bd8b12d51d 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs-vcs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.24 2010/09/13 08:44:13 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.25 2010/09/22 20:35:57 ulm Exp $
+
+ 22 Sep 2010; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-24.0.9999.ebuild:
+ Add messages to "die" commands.
13 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
emacs-vcs-24.0.9999.ebuild, metadata.xml:
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
index b450f0c88e49..4db8325805d5 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.10 2010/09/13 08:44:13 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.11 2010/09/22 20:35:57 ulm Exp $
EAPI=2
@@ -104,20 +104,20 @@ src_prepare() {
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
- "${S}"/src/s/freebsd.h || die
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
if ! use alsa; then
# ALSA is detected even if not requested by its USE flag.
# Suppress it by supplying pkg-config with a wrong library name.
sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
- || die
+ || die "unable to sed configure.in"
fi
if ! use gzip-el; then
# Emacs' build system automatically detects the gzip binary and
# compresses el files. We don't want that so confuse it with a
# wrong binary name
sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
- || die
+ || die "unable to sed configure.in"
fi
eautoreconf
@@ -202,37 +202,37 @@ src_configure() {
--infodir=/usr/share/info/${EMACS_SUFFIX} \
--with-crt-dir=/usr/$(get_libdir) \
--without-compress-info \
- ${myconf} || die
+ ${myconf} || die "econf emacs failed"
}
src_compile() {
export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
if [ "${PV##*.}" = "9999" ]; then
- emake CC="$(tc-getCC)" bootstrap || die
+ emake CC="$(tc-getCC)" bootstrap || die "make bootstrap failed"
# cleanup, otherwise emacs will be dumped again in src_install
(cd src; emake versionclean)
fi
- emake CC="$(tc-getCC)" || die
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install () {
local i m
- emake install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}" || die "make install failed"
rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
- || die
+ || die "removing duplicate emacs executable failed"
mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
- || die
+ || die "moving Emacs executable failed"
# move info documentation to the correct place
for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
- mv "${i}" "${i}.info" || die
+ mv "${i}" "${i}.info" || die "mv info failed"
done
# move man pages to the correct place
for m in "${D}"/usr/share/man/man1/* ; do
- mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die
+ mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
done
# avoid collision between slots, see bug #169033 e.g.
@@ -270,7 +270,7 @@ src_install () {
EOF
elisp-site-file-install "${T}/${SITEFILE}" || die
- dodoc README BUGS || die
+ dodoc README BUGS || die "dodoc failed"
}
emacs-infodir-rebuild() {