summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-07-04 14:15:47 +0000
committerMamoru Komachi <usata@gentoo.org>2004-07-04 14:15:47 +0000
commit90b7c50ec3081f8c723a4da35a29dcd2d2cfb62e (patch)
treebce2761ad2994477524862c4a2e1fb58bfd016ab /app-editors/emacs/emacs-21.3-r2.ebuild
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-90b7c50ec3081f8c723a4da35a29dcd2d2cfb62e.tar.gz
gentoo-2-90b7c50ec3081f8c723a4da35a29dcd2d2cfb62e.tar.bz2
gentoo-2-90b7c50ec3081f8c723a4da35a29dcd2d2cfb62e.zip
Added partial SLOT support. Reversed Xaw3d and motif USE flag order, see bug #18518
Diffstat (limited to 'app-editors/emacs/emacs-21.3-r2.ebuild')
-rw-r--r--app-editors/emacs/emacs-21.3-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-editors/emacs/emacs-21.3-r2.ebuild b/app-editors/emacs/emacs-21.3-r2.ebuild
index c9540501ced9..e3ae04c0d53c 100644
--- a/app-editors/emacs/emacs-21.3-r2.ebuild
+++ b/app-editors/emacs/emacs-21.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.15 2004/06/24 21:53:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.16 2004/07/04 14:15:47 usata Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc alpha amd64 hppa ia64 s390"
+KEYWORDS="x86 ppc sparc alpha amd64 hppa ia64 s390"
IUSE="X nls motif leim gnome Xaw3d"
RDEPEND="sys-libs/ncurses
@@ -55,10 +55,10 @@ src_compile() {
--with-tiff
--with-gif
--with-png"
- if use motif ; then
- myconf="${myconf} --with-x-toolkit=motif"
- elif use Xaw3d ; then
+ if use Xaw3d ; then
myconf="${myconf} --with-x-toolkit=athena"
+ elif use motif ; then
+ myconf="${myconf} --with-x-toolkit=motif"
else
# do not build emacs with any toolkit, bug 35300
myconf="${myconf} --with-x-toolkit=no"