summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-08-04 18:22:45 +0000
committerPeter Gavin <pete@gentoo.org>2001-08-04 18:22:45 +0000
commit2104e6db8dc8fa0ead9a8c4ebebe51334d118641 (patch)
treeb77f143824f93937008d0135d208ecbafe8a28ee /app-editors/emacs
parentweb updates (diff)
downloadgentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.tar.gz
gentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.tar.bz2
gentoo-2-2104e6db8dc8fa0ead9a8c4ebebe51334d118641.zip
*** empty log message ***
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-20.7.ebuild54
-rw-r--r--app-editors/emacs/emacs-21.0.103.ebuild58
2 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-20.7.ebuild b/app-editors/emacs/emacs-20.7.ebuild
new file mode 100644
index 000000000000..b2ba603fddf6
--- /dev/null
+++ b/app-editors/emacs/emacs-20.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${A}"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ X? ( virtual/x11 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+ if [ "`use X`" ] ; then
+ myconf="${myconf} --with-x"
+ else
+ myconf="${myconf} --without-x"
+ fi
+ if [ "`use motif`" ] ; then
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+
+ try ./configure --prefix=/usr --libexecdir=/usr/lib --host=${CHOST} \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ try make ${MAKEOPTS}
+}
+
+src_install () {
+ try make prefix=${D}/usr libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ cd ${D}/usr/share/info
+ rm dir
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+ dodoc BUGS ChangeLog README
+}
+
+
+
+
+
diff --git a/app-editors/emacs/emacs-21.0.103.ebuild b/app-editors/emacs/emacs-21.0.103.ebuild
new file mode 100644
index 000000000000..77f4b3d18e46
--- /dev/null
+++ b/app-editors/emacs/emacs-21.0.103.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.eecs.umich.edu/pub/NetBSD/packages/distfiles/LOCAL_PORTS/${A}"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ X? ( virtual/x11
+ media-libs/libungif-4.1.0
+ media-libs/jpeg-6b-r2
+ media-libs/tiff-3.5.5-r3
+ media-libs/libpng-1.0.9 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+ if [ "`use X`" ] ; then
+ myconf="${myconf} --with-x --with-xpm --with-jpeg --with-tiff --with-gif --with-png"
+ else
+ myconf="${myconf} --without-x"
+ fi
+ if [ "`use motif`" ] ; then
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+
+ try ./configure --prefix=/usr --libexecdir=/usr/lib --host=${CHOST} \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ try make ${MAKEOPTS}
+}
+
+src_install () {
+ try make prefix=${D}/usr libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ cd ${D}/usr/share/info
+ rm dir
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+ dodoc BUGS ChangeLog README
+}
+
+
+
+
+