summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-07-24 15:49:03 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-07-24 15:49:03 +0000
commit01e60419d1761387b61a12039c4112bb491d3f2b (patch)
tree67763994cc2ff5ea9f641bf76d4ac56634e5e4ac /app-editors/gedit-plugins
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-01e60419d1761387b61a12039c4112bb491d3f2b.tar.gz
gentoo-2-01e60419d1761387b61a12039c4112bb491d3f2b.tar.bz2
gentoo-2-01e60419d1761387b61a12039c4112bb491d3f2b.zip
Fix RDEPEND, some dependencies was missing. Drop ${MY_PV}, Increase eapi to 2 and fix missing terminal? ( >=x11-libs/vte-0.19.4[python] ) dep, bug 28470
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog7
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild40
-rw-r--r--app-editors/gedit-plugins/metadata.xml3
3 files changed, 30 insertions, 20 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 90b29466e253..458c2af92946 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.2 2009/07/22 19:49:52 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.3 2009/07/24 15:49:03 mrpouet Exp $
+
+ 24 Jul 2009; Romain Perier <mrpouet@gentoo.org> gedit-plugins-2.26.2.ebuild,
+ metadata.xml:
+ Fix RDEPEND, some dependencies was missing. Drop ${MY_PV}, Increase eapi to
+ 2 and fix missing terminal? ( >=x11-libs/vte-0.19.4[python] ) dep, bug 28470.
23 Jul 2009; Romain Perier <mrpouet@gentoo.org> gedit-plugins-2.26.2.ebuild,
metadata.xml:
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild
index 99f02bdc57c0..2362ebdb3ee5 100644
--- a/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild,v 1.2 2009/07/22 19:49:52 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.26.2.ebuild,v 1.3 2009/07/24 15:49:03 mrpouet Exp $
-EAPI="1"
+EAPI="2"
GCONF_DEBUG="no"
inherit gnome2
-MY_PV=${PV#*.}
-
DESCRIPTION="Offical plugins for gedit."
HOMEPAGE="http://live.gnome.org/GeditPlugins"
@@ -16,18 +14,26 @@ LICENSE="GPL-2"
KEYWORDS="~amd64"
SLOT="0"
-IUSE="bookmarks +bracketcompletion charmap +codecomment colorpicker +drawspaces +joinlines python +session showtabbar smartspaces terminal"
+IUSE="bookmarks +bracketcompletion charmap colorpicker +drawspaces +joinlines python +session showtabbar smartspaces terminal"
-RDEPEND=">=x11-libs/gtk+-2.14
- gnome-base/gconf
- >=x11-libs/gtksourceview-2.6
- >=app-editors/gedit-2.26.1
- python? (
- >=dev-python/pygobject-2.15.4
- >=dev-python/pygtk-2.12.0
- >=dev-python/pygtksourceview-2.2.0
- )"
+RDEPEND=">=x11-libs/gtk+-2.14
+ gnome-base/gconf
+ >=x11-libs/gtksourceview-2.6
+ >=app-editors/gedit-2.26.1[python]
+ >=dev-python/pygtk-2.14
+ charmap? (
+ >=gnome-extra/gucharmap-2.24.3
+ )
+ session? (
+ dev-lang/python[xml]
+ )
+ python? (
+ >=dev-python/pygtksourceview-2.2.0
+ )
+ terminal? (
+ >=x11-libs/vte-0.19.4[python]
+ )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
@@ -36,13 +42,13 @@ DOCS="AUTHORS NEWS"
pkg_setup()
{
- local myplugins=
+ local myplugins="codecomment"
for plugin in ${IUSE/python}; do
if use session && [ "${plugin/+}" = "session" ]; then
- myplugins="${myplugins:+${myplugins},}sessionsaver"
+ myplugins="${myplugins},sessionsaver"
elif use ${plugin/+}; then
- myplugins="${myplugins:+${myplugins},}${plugin/+}"
+ myplugins="${myplugins},${plugin/+}"
fi
done
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
index b72197bc33fd..06f9256139af 100644
--- a/app-editors/gedit-plugins/metadata.xml
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -10,8 +10,7 @@
<use>
<flag name='bookmarks'>Advanced Bookmarking, it remembers all the bookmarks you ever toggled, highlights them in the text and allows you to navigate through a list with the navigation pane</flag>
<flag name='bracketcompletion'>Automatically adds closing brackets</flag>
- <flag name='charmap'> Insert special characters just by clicking on them</flag>
- <flag name='codecomment'>Comment and uncomment blocks of code</flag>
+ <flag name='charmap'> Insert special characters just by clicking on them</flag>
<flag name='colorpicker'>Pick a color from a dialog and insert its hexadecimal representation</flag>
<flag name='drawspaces'>Draw spaces and tabs</flag>
<flag name='joinlines'>Join several lines or split long ones</flag>