summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-26 12:53:54 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-26 12:53:54 +0000
commit0a635615bcac12e54e13a1ace618ee4733700786 (patch)
treee5c2ceb970139517c606947d034c132d933a0bef /app-editors/gedit-plugins
parentadd live ebuild (diff)
downloadgentoo-2-0a635615bcac12e54e13a1ace618ee4733700786.tar.gz
gentoo-2-0a635615bcac12e54e13a1ace618ee4733700786.tar.bz2
gentoo-2-0a635615bcac12e54e13a1ace618ee4733700786.zip
Adapt upstream patch from master to let terminal plugin work again
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog10
-rw-r--r--app-editors/gedit-plugins/files/gedit-plugins-3.8.3-terminal-background.patch11
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.8.2.ebuild66
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.8.3-r1.ebuild (renamed from app-editors/gedit-plugins/gedit-plugins-3.8.3.ebuild)8
4 files changed, 27 insertions, 68 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index ea396a088a23..072374ec19ca 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.36 2013/08/31 01:10:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.37 2013/10/26 12:53:54 pacho Exp $
+
+*gedit-plugins-3.8.3-r1 (26 Oct 2013)
+
+ 26 Oct 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gedit-plugins-3.8.3-terminal-background.patch,
+ +gedit-plugins-3.8.3-r1.ebuild, -gedit-plugins-3.8.2.ebuild,
+ -gedit-plugins-3.8.3.ebuild:
+ Adapt upstream patch from master to let terminal plugin work again
31 Aug 2013; Patrick Lauer <patrick@gentoo.org>
-gedit-plugins-3.6.1-r1.ebuild:
diff --git a/app-editors/gedit-plugins/files/gedit-plugins-3.8.3-terminal-background.patch b/app-editors/gedit-plugins/files/gedit-plugins-3.8.3-terminal-background.patch
new file mode 100644
index 000000000000..9dc162fd9807
--- /dev/null
+++ b/app-editors/gedit-plugins/files/gedit-plugins-3.8.3-terminal-background.patch
@@ -0,0 +1,11 @@
+--- plugins/terminal/terminal.py~ 2013-06-18 12:16:09.000000000 +0200
++++ plugins/terminal/terminal.py 2013-10-26 14:49:48.619158171 +0200
+@@ -58,8 +58,6 @@
+ self.system_settings.connect("changed::monospace-font-name", self.font_changed)
+
+ self._vte = Vte.Terminal()
+- self._vte.set_background_image(None)
+- self._vte.set_background_transparent(False)
+ self.reconfigure_vte()
+ self._vte.set_size(self._vte.get_column_count(), 5)
+ self._vte.set_size_request(200, 50)
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.8.2.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.8.2.ebuild
deleted file mode 100644
index ce709bf7dd38..000000000000
--- a/app-editors/gedit-plugins/gedit-plugins-3.8.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.8.2.ebuild,v 1.1 2013/05/26 11:05:42 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_2 )
-PYTHON_REQ_USE="xml"
-
-inherit eutils gnome2 multilib python-r1
-
-DESCRIPTION="Official plugins for gedit"
-HOMEPAGE="http://live.gnome.org/GeditPlugins"
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-IUSE_plugins="charmap terminal"
-IUSE="+python ${IUSE_plugins}"
-REQUIRED_USE="charmap? ( python ) terminal? ( python )"
-
-RDEPEND="
- >=app-editors/gedit-3.7.1[python?]
- >=dev-libs/glib-2.32:2
- >=dev-libs/libpeas-1.7.0[gtk,python?]
- >=x11-libs/gtk+-3.4:3
- >=x11-libs/gtksourceview-3:3.0
- python? (
- ${PYTHON_DEPS}
- >=app-editors/gedit-3[introspection,${PYTHON_USEDEP}]
- dev-libs/libpeas[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pycairo
- dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
- >=x11-libs/gtk+-3.4:3[introspection]
- >=x11-libs/gtksourceview-3:3.0[introspection]
- x11-libs/pango[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- )
- charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
- terminal? ( x11-libs/vte:2.90[introspection] )
-"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40.0
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- # DEFAULT_PLUGINS from configure.ac
- local myplugins="bookmarks,drawspaces,wordcompletion"
-
- # python plugins with no extra dependencies beyond what USE=python brings
- use python && myplugins="${myplugins},bracketcompletion,codecomment,colorpicker,colorschemer,commander,dashboard,joinlines,multiedit,textsize,smartspaces,synctex"
-
- # python plugins with extra dependencies
- for plugin in ${IUSE_plugins/+}; do
- use ${plugin} && myplugins="${myplugins},${plugin}"
- done
-
- gnome2_src_configure \
- --with-plugins=${myplugins} \
- $(use_enable python)
-}
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.8.3.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.8.3-r1.ebuild
index 97788c96f532..4c398941bba3 100644
--- a/app-editors/gedit-plugins/gedit-plugins-3.8.3.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-3.8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.8.3.ebuild,v 1.3 2013/07/25 22:30:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.8.3-r1.ebuild,v 1.1 2013/10/26 12:53:54 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -54,6 +54,12 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+src_prepare() {
+ # Fix terminal not loading (adapted from 'master')
+ epatch "${FILESDIR}/${PN}-3.8.3-terminal-background.patch"
+ gnome2_src_prepare
+}
+
src_configure() {
# DEFAULT_PLUGINS from configure.ac
local myplugins="bookmarks,drawspaces,wordcompletion"