summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-16 21:44:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-16 21:44:44 +0000
commitb0b25ad28b218437432f3b02ceb82d9b07412a6b (patch)
treeb900488e124ef0463ae51076cd211d49ae5962e1 /app-editors/gedit
parentVersion bump (diff)
downloadgentoo-2-b0b25ad28b218437432f3b02ceb82d9b07412a6b.tar.gz
gentoo-2-b0b25ad28b218437432f3b02ceb82d9b07412a6b.tar.bz2
gentoo-2-b0b25ad28b218437432f3b02ceb82d9b07412a6b.zip
Bump to 2.22.3-r2. Adapt upstream patch to fix CVE-2009-0314, bug #257004.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog8
-rw-r--r--app-editors/gedit/files/gedit-2.22.3-CVE-2009-0314.patch24
-rw-r--r--app-editors/gedit/gedit-2.22.3-r2.ebuild93
3 files changed, 124 insertions, 1 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 00eeace5f8b2..4f6a87ed1b23 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.262 2009/03/15 22:29:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.263 2009/03/16 21:44:43 eva Exp $
+
+*gedit-2.22.3-r2 (16 Mar 2009)
+
+ 16 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gedit-2.22.3-CVE-2009-0314.patch, +gedit-2.22.3-r2.ebuild:
+ Bump to 2.22.3-r2. Adapt upstream patch to fix CVE-2009-0314, bug #257004.
15 Mar 2009; Markus Meier <maekke@gentoo.org> gedit-2.24.3.ebuild:
x86 stable, bug #260063
diff --git a/app-editors/gedit/files/gedit-2.22.3-CVE-2009-0314.patch b/app-editors/gedit/files/gedit-2.22.3-CVE-2009-0314.patch
new file mode 100644
index 000000000000..6dc03a921698
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.22.3-CVE-2009-0314.patch
@@ -0,0 +1,24 @@
+# https://bugzilla.gnome.org/show_bug.cgi?id=569214
+# https://bugzilla.redhat.com/show_bug.cgi?id=481556
+# https://bugs.gentoo.org/show_bug.cgi?id=257004
+--- a/gedit/gedit-python-module.c 2009-03-16 22:18:36.000000000 +0100
++++ b/gedit/gedit-python-module.c 2009-03-16 22:18:48.000000000 +0100
+@@ -398,7 +398,7 @@
+ PyObject *gettext, *install, *gettext_args;
+ struct sigaction old_sigint;
+ gint res;
+- char *argv[] = { "gedit", NULL };
++ char *argv[] = { GEDIT_PLUGINS_LIBS_DIR, NULL };
+
+ static gboolean init_failed = FALSE;
+
+--- a/gedit/Makefile.am 2009-03-16 22:18:55.000000000 +0100
++++ b/gedit/Makefile.am 2009-03-16 22:19:29.000000000 +0100
+@@ -24,6 +24,7 @@
+ $(NO_STRICT_ALIASING_CFLAGS) \
+ $(PYGTK_CFLAGS) \
+ $(PYTHON_CFLAGS) \
++ -DGEDIT_PLUGINS_LIBS_DIR=\"$(libdir)/gedit-2/plugins\" \
+ $(AM_CFLAGS)
+ endif
+
diff --git a/app-editors/gedit/gedit-2.22.3-r2.ebuild b/app-editors/gedit/gedit-2.22.3-r2.ebuild
new file mode 100644
index 000000000000..c270f4c2aca8
--- /dev/null
+++ b/app-editors/gedit/gedit-2.22.3-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.22.3-r2.ebuild,v 1.1 2009/03/16 21:44:43 eva Exp $
+
+inherit gnome2 python eutils autotools
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python spell xattr"
+
+RDEPEND=">=gnome-base/gconf-2
+ xattr? ( sys-apps/attr )
+ >=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.12
+ >=x11-libs/gtksourceview-2.2
+ >=gnome-base/libgnomeui-2.16
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/gnome-vfs-2.16
+ spell? (
+ >=app-text/enchant-1.2
+ app-text/iso-codes
+ )
+ python? (
+ >=dev-python/pygobject-2.12
+ >=dev-python/pygtk-2.12
+ >=dev-python/pygtksourceview-2.2
+ >=dev-python/gnome-vfs-python-2.22.1
+ >=dev-python/libgnome-python-2.22.1
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ gnome-base/gnome-common
+ >=dev-util/gtk-doc-am-1
+ doc? ( >=dev-util/gtk-doc-1 )"
+# gnome-common and gtk-doc-am needed to eautoreconf
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+ # HACK HACK HACK: someone fix this garbage
+ MAKEOPTS="${MAKEOPTS} -j1"
+fi
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ $(use_enable python)
+ $(use_enable spell)
+ $(use_enable xattr attr)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Remove symbols that are not meant to be part of the docs, and
+ # break compilation if USE="doc -python" (bug #158638).
+ if use !python && use doc; then
+ epatch "${FILESDIR}"/${PN}-2.16.2-no_python_module_docs.patch
+ fi
+
+ # chown on fbsd doesn't have --reference. Bug #183691
+ epatch "${FILESDIR}"/${PN}-2.18.1-fbsd.patch
+
+ # fixes failing python test due to libtool 2.2, bug #216110
+ epatch "${FILESDIR}/${PN}-2.22.1-fix-libtool-2.2.patch"
+
+ # fix for CVE-2009-0314, bug #257004
+ epatch "${FILESDIR}/${P}-CVE-2009-0314.patch"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}