summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-08-29 13:52:52 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-08-29 13:52:52 +0000
commit837281a9e910dae0580521077316aa9516d27762 (patch)
treed02794d72effac6ad94ddd9df429b47b94577f08 /app-editors/gobby
parentbump (diff)
downloadgentoo-2-837281a9e910dae0580521077316aa9516d27762.tar.gz
gentoo-2-837281a9e910dae0580521077316aa9516d27762.tar.bz2
gentoo-2-837281a9e910dae0580521077316aa9516d27762.zip
bump
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog8
-rw-r--r--app-editors/gobby/files/digest-gobby-0.4.0_rc43
-rw-r--r--app-editors/gobby/gobby-0.4.0_rc4.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 1e64fda9ca34..529ab54a8f8f 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.10 2006/06/12 16:29:39 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.11 2006/08/29 13:52:52 humpback Exp $
+
+*gobby-0.4.0_rc4 (29 Aug 2006)
+
+ 29 Aug 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ -gobby-0.4.0_rc2.ebuild, +gobby-0.4.0_rc4.ebuild:
+ Bumped to rc4.
*gobby-0.4.0_rc2 (12 Jun 2006)
diff --git a/app-editors/gobby/files/digest-gobby-0.4.0_rc4 b/app-editors/gobby/files/digest-gobby-0.4.0_rc4
new file mode 100644
index 000000000000..d24cc6024a22
--- /dev/null
+++ b/app-editors/gobby/files/digest-gobby-0.4.0_rc4
@@ -0,0 +1,3 @@
+MD5 d8c8e682afcbc69e9390a3e4c5c0501a gobby-0.4.0rc4.tar.gz 353957
+RMD160 981b86f0ba4125170f85526076f5f6e02fc122da gobby-0.4.0rc4.tar.gz 353957
+SHA256 849caa03cd3f07329cf5ade77c623e8e94cfa3d13003358b24e3dcad00c1f14c gobby-0.4.0rc4.tar.gz 353957
diff --git a/app-editors/gobby/gobby-0.4.0_rc4.ebuild b/app-editors/gobby/gobby-0.4.0_rc4.ebuild
new file mode 100644
index 000000000000..74b36e160a94
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.0_rc4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.0_rc4.ebuild,v 1.1 2006/08/29 13:52:52 humpback Exp $
+
+inherit eutils
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://darcs.0x539.de/gobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-cpp/gtkmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=net-libs/obby-0.4.0_rc4
+ >=dev-cpp/libxmlpp-2.6
+ >=x11-libs/gtksourceview-1.2.0"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_compile() {
+ econf --with-gtksourceview `use_with gnome` || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ insinto /usr/share/applications
+ newins ${FILESDIR}/${PN}.desktop-r1 ${PN}.desktop
+}
+
+pkg_postinst() {
+ if built_with_use net-libs/obby howl
+ then
+ einfo "Zeroconf support has been enabled for gobby"
+ else
+ einfo "net-libs/obby was not build with zeroconf support,"
+ einfo "thus zeroconf is not enabled for ${PN}."
+ einfo ""
+ einfo "To get zeroconf support, rebuild net-libs/obby"
+ einfo "with \"howl\" in your USE flags."
+ einfo "Try USE=\"howl\" emerge net-libs/obby app-editors/gobby,"
+ einfo "or add \"howl\" to your USE string in /etc/make.conf and"
+ einfo "emerge net-libs/obby"
+ fi
+}