summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-06-11 15:59:24 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-06-11 15:59:24 +0000
commitb50efc09208032597dbb86eb5d10f6f8abee5a86 (patch)
tree6cc543a255b40f22f5060fe62afd4d433b5f83eb /app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild
parentChange callgrind to newer valgrind or callgrind depend thanks to Daniel Frank... (diff)
downloadgentoo-2-b50efc09208032597dbb86eb5d10f6f8abee5a86.tar.gz
gentoo-2-b50efc09208032597dbb86eb5d10f6f8abee5a86.tar.bz2
gentoo-2-b50efc09208032597dbb86eb5d10f6f8abee5a86.zip
Fixes compilation error by not testing for termcap; Resolves Bug #134813.
(Portage version: 2.1)
Diffstat (limited to 'app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild')
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild
new file mode 100644
index 000000000000..1984e3fee4c5
--- /dev/null
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20050505-r3.ebuild,v 1.1 2006/06/11 15:59:24 mkennedy Exp $
+
+inherit eutils
+
+MY_PV=${PV} # 20021205 -> 021205
+
+DESCRIPTION="Jasspa Microemacs"
+HOMEPAGE="http://www.jasspa.com/"
+SRC_URI="http://www.jasspa.com/release_${PV}/jasspa-memacros-${PV}.tar.gz
+ http://www.jasspa.com/release_${PV}/jasspa-mehtml-${PV}.tar.gz
+ http://www.jasspa.com/release_${PV}/jasspa-mesrc-${PV}.tar.gz
+ http://www.jasspa.com/release_${PV}/meicons-extra.tar.gz"
+# http://www.jasspa.com/release_${MY_PV}/me.ehf.gz
+# http://www.jasspa.com/release_${MY_PV}/meicons.tar.gz
+## http://www.jasspa.com/spelling/ls_enus.tar.gz
+## http://www.jasspa.com/release_${MY_PV}/readme.jasspa_gnome
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="X"
+
+DEPEND="virtual/libc
+ sys-libs/ncurses
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )"
+
+S="${WORKDIR}/me${PV:2}/src"
+
+src_unpack() {
+ unpack jasspa-mesrc-${PV}.tar.gz
+ cd ${T}
+ # everything except jasspa-mesrc
+ unpack ${A/jasspa-mesrc-${PV}.tar.gz/}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-ncurses.patch
+}
+
+src_compile() {
+ sed -i "/^COPTIMISE/s/.*/COPTIMISE = ${CFLAGS}/" linux{2,26}.gmk
+ local loadpath="~/.jasspa:/usr/share/jasspa/site:/usr/share/jasspa"
+ if use X
+ then
+ ./build -p "$loadpath"
+ else
+ ./build -t c -p "$loadpath"
+ fi
+}
+
+src_install() {
+ dodir /usr/share/jasspa
+ keepdir /usr/share/jasspa/site
+ if use X; then
+ newbin me me32 || die
+ dobin me || die
+ else
+ dobin mec || die
+ dosym /usr/bin/mec /usr/bin/me
+ fi
+ dodoc ../*.txt ../change.log
+ cp -r ${T}/* ${D}/usr/share/jasspa
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/jasspa-microemacs.desktop
+}