summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-10-19 12:22:53 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-10-19 12:22:53 +0000
commit0781fa1a3abfeca537bc15936b1a5ef3aa628d9a (patch)
treeba991c73475419762a4693a0ea4e94ec11b061ff /app-editors/jedit
parentadded jikes flag (used by several ebuilds) (diff)
downloadgentoo-2-0781fa1a3abfeca537bc15936b1a5ef3aa628d9a.tar.gz
gentoo-2-0781fa1a3abfeca537bc15936b1a5ef3aa628d9a.tar.bz2
gentoo-2-0781fa1a3abfeca537bc15936b1a5ef3aa628d9a.zip
re-enabled compilation with >=jikes-1.17
Diffstat (limited to 'app-editors/jedit')
-rw-r--r--app-editors/jedit/ChangeLog6
-rw-r--r--app-editors/jedit/jedit-4.0.3-r1.ebuild19
-rw-r--r--app-editors/jedit/jedit-4.0.3-r2.ebuild19
-rw-r--r--app-editors/jedit/jedit-4.0.3.ebuild19
-rw-r--r--app-editors/jedit/jedit-4.0.ebuild11
5 files changed, 41 insertions, 33 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index 485303ca1c0c..bb9c9229880e 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/jedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.7 2002/10/18 21:15:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.8 2002/10/19 12:22:53 blizzy Exp $
+
+ 19 Oct 2002; Maik Schreiber <blizzy@gentoo.org> jedit-4.0.ebuild,
+ jedit-4.0.3.ebuild, jedit-4.0.3-r1.ebuild, jedit-4.0.3-r2.ebuild:
+ Re-enabled compilation with >=jikes-1.17.
06 Aug 2002; Maik Schreiber <blizzy@gentoo.org> jedit-4.0.ebuild,
jedit-4.0.3.ebuild, jedit-4.0.3-r1.ebuild, jedit-4.0.3-r2.ebuild:
diff --git a/app-editors/jedit/jedit-4.0.3-r1.ebuild b/app-editors/jedit/jedit-4.0.3-r1.ebuild
index 2e973386a05e..8fd401c18e72 100644
--- a/app-editors/jedit/jedit-4.0.3-r1.ebuild
+++ b/app-editors/jedit/jedit-4.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.4 2002/10/18 21:15:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.5 2002/10/19 12:22:53 blizzy Exp $
MY_PV=${PV//.}
S="${WORKDIR}/jEdit"
@@ -9,22 +9,23 @@ HOMEPAGE="http://www.jedit.org"
SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="*"
+KEYWORDS="x86"
+IUSE="jikes"
RDEPEND=">=virtual/jdk-1.3"
DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1"
-# jikes? ( >=dev-java/jikes-1.15 )"
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
src_compile() {
local antflags
antflags=""
-# if [ `use jikes` ] ; then
-# einfo "Please ignore the following compiler warnings."
-# einfo "Jikes is just too pedantic..."
-# antflags="${antflags} -Dbuild.compiler=jikes"
-# fi
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
ant ${antflags} || die "compile problem"
}
diff --git a/app-editors/jedit/jedit-4.0.3-r2.ebuild b/app-editors/jedit/jedit-4.0.3-r2.ebuild
index af44420ffc13..cb7de9fa7f15 100644
--- a/app-editors/jedit/jedit-4.0.3-r2.ebuild
+++ b/app-editors/jedit/jedit-4.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r2.ebuild,v 1.3 2002/10/18 21:15:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r2.ebuild,v 1.4 2002/10/19 12:22:53 blizzy Exp $
MY_PV=${PV//.}
S="${WORKDIR}/jEdit"
@@ -9,22 +9,23 @@ HOMEPAGE="http://www.jedit.org"
SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="*"
+KEYWORDS="x86"
+IUSE="jikes"
RDEPEND=">=virtual/jdk-1.3"
DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1"
-# jikes? ( >=dev-java/jikes-1.15 )"
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
src_compile() {
local antflags
antflags=""
-# if [ `use jikes` ] ; then
-# einfo "Please ignore the following compiler warnings."
-# einfo "Jikes is just too pedantic..."
-# antflags="${antflags} -Dbuild.compiler=jikes"
-# fi
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
ant ${antflags} || die "compile problem"
}
diff --git a/app-editors/jedit/jedit-4.0.3.ebuild b/app-editors/jedit/jedit-4.0.3.ebuild
index 0cfdf0c8b1fb..a7ac02fd5e20 100644
--- a/app-editors/jedit/jedit-4.0.3.ebuild
+++ b/app-editors/jedit/jedit-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3.ebuild,v 1.5 2002/10/18 21:15:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3.ebuild,v 1.6 2002/10/19 12:22:53 blizzy Exp $
MY_PV=${PV//.}
S="${WORKDIR}/jEdit"
@@ -9,22 +9,23 @@ HOMEPAGE="http://www.jedit.org"
SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="*"
+KEYWORDS="x86"
+IUSE="jikes"
RDEPEND=">=virtual/jdk-1.3"
DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1"
-# jikes? ( >=dev-java/jikes-1.15 )"
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
src_compile() {
local antflags
antflags=""
-# if [ `use jikes` ] ; then
-# einfo "Please ignore the following compiler warnings."
-# einfo "Jikes is just too pedantic..."
-# antflags="${antflags} -Dbuild.compiler=jikes"
-# fi
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
ant ${antflags} || die "compile problem"
}
diff --git a/app-editors/jedit/jedit-4.0.ebuild b/app-editors/jedit/jedit-4.0.ebuild
index 4d3d25a76f6c..8c174eb6b945 100644
--- a/app-editors/jedit/jedit-4.0.ebuild
+++ b/app-editors/jedit/jedit-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Maik Schreiber
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.ebuild,v 1.4 2002/10/18 21:15:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.ebuild,v 1.5 2002/10/19 12:22:53 blizzy Exp $
MY_PV=${PV//.}
S="${WORKDIR}/jEdit"
@@ -9,18 +9,19 @@ HOMEPAGE="http://www.jedit.org"
SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="*"
+KEYWORDS="x86"
+IUSE="jikes"
RDEPEND=">=virtual/jdk-1.3"
DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1"
-# jikes? ( >=dev-java/jikes-1.15 )"
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
src_compile() {
local antflags
antflags=""
-# use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compile problem"
}