summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-06-11 22:32:43 +0000
committerVlastimil Babka <caster@gentoo.org>2009-06-11 22:32:43 +0000
commit9a6ce67459fedcb63f3ea241547e562830e2c8fd (patch)
treeb98312d9e671bfab8b0a84a5d94755fad9ded571 /app-editors/jext
parentstable sparc, bug 273076 (diff)
downloadgentoo-2-9a6ce67459fedcb63f3ea241547e562830e2c8fd.tar.gz
gentoo-2-9a6ce67459fedcb63f3ea241547e562830e2c8fd.tar.bz2
gentoo-2-9a6ce67459fedcb63f3ea241547e562830e2c8fd.zip
Version bump, adpated from java-experimental.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/jext')
-rw-r--r--app-editors/jext/ChangeLog10
-rw-r--r--app-editors/jext/files/jext-pre91
-rw-r--r--app-editors/jext/jext-5.0.ebuild58
3 files changed, 157 insertions, 2 deletions
diff --git a/app-editors/jext/ChangeLog b/app-editors/jext/ChangeLog
index 38c06f1f51f4..d9b2301d42e4 100644
--- a/app-editors/jext/ChangeLog
+++ b/app-editors/jext/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jext
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.17 2009/01/10 13:20:37 ali_bush Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/ChangeLog,v 1.18 2009/06/11 22:32:43 caster Exp $
+
+*jext-5.0 (11 Jun 2009)
+
+ 11 Jun 2009; Vlastimil Babka <caster@gentoo.org> +jext-5.0.ebuild,
+ +files/jext-pre:
+ Version bump, adpated from java-experimental.
10 Jan 2009; Alistair Bush <ali_bush@gentoo.org> jext-3.2_pre3-r1.ebuild:
Fixed incorrect LICENSE. see #252951
diff --git a/app-editors/jext/files/jext-pre b/app-editors/jext/files/jext-pre
new file mode 100644
index 000000000000..5a02d4b71db8
--- /dev/null
+++ b/app-editors/jext/files/jext-pre
@@ -0,0 +1,91 @@
+# This script launches Jext, the Java text editor.
+# It checks for a $HOME/.jext directory and eventually creates it.
+# Next it checks for a /etc/jextrc and $JEXT_CONFFILE (~/.jext/variables) files which define the JEXT_HOME JAVA_CMD JAVA_OPT CLASSPATH and ToShow variables. The first is system wide(used in RPM install mainly), the second is per user.
+# If this file doesn't exist the script creates it by asking the options to the user.
+
+# Sharpshooter 23/02/2002
+# Blaisorblade 18/11/2002
+
+#For special cases about different config files(for developers with working
+#copy and an unstable one to be tested).
+if [ "$JEXT_CONFFILE" = "" ]
+then
+ JEXT_CONFFILE=~/.jext/variables
+fi
+
+# Help
+if [ "$1" = "--help" -o "$1" = "-h" ]
+then
+ echo "This script launch Jext the Java text editor."
+ echo "Usage : $0 [--reconf] [files]"
+ echo "--reconf doesn't start jext but clears the"
+ echo " $JEXT_CONFFILE file with the settings to start jext"
+ echo " (jext & java location and jext options)."
+ exit 0
+fi
+
+if [ "$1" = "--reconf" ]
+then
+ echo "Clearing $JEXT_CONFFILE, you'll have to reenter jext & java \
+interpreter location"
+ rm -f "$JEXT_CONFFILE"
+ exit 0
+fi
+
+
+# Check for the user's ~/.jext directory.
+if ! [ -d ~/.jext ]
+then
+ echo "It seems you don't have a .jext directory in your home dir."
+ echo "I create it."
+ echo
+ mkdir -p ~/.jext/xinsert
+fi
+
+
+
+# Check for the $HOME/.jext/variables file.
+if ! [ -f $JEXT_CONFFILE -o -f /etc/jextrc ]
+then
+ #Let's add some explaination in the config file.
+ cat >$JEXT_CONFFILE <<EOM
+#This is included when launching Jext. It is a normal shell script \
+used to define env vars
+#Meanings of settings:
+#JEXT_HOME The home dir of jext(under which it finds the lib and so on dirs)
+#JAVA_CMD The complete path for the java command
+#JAVA_OPT The options to be passed to the java command(not to Jext itself!)
+#CLASSPATH The extra classpath to be specified(for cases such as AntWork plugin)
+#ToShow If this is set to y the output is not redirected to /dev/null;
+# Mainly for developers who want to trace Jext output(you could also use
+# the DickTracy plugin).
+EOM
+#----
+ JEXT_HOME="/usr/share/jext/lib"
+ echo "JEXT_HOME="$JEXT_HOME >> $JEXT_CONFFILE
+#----
+ ToShow=
+ echo "ToShow="$ToShow>>$JEXT_CONFFILE
+fi
+
+# Extract the contents of the $JEXT_CONFFILE file.
+[ -f /etc/jextrc ] && source /etc/jextrc
+[ -f $JEXT_CONFFILE ] && source $JEXT_CONFFILE
+
+#Needed to make Jext find his plugins(it searches them in `pwd`/plugins)
+for i in $@
+do
+ if [ "${i:0:1}" != "/" -a "${i:0:1}" != "-" ]; then #If the first char of $i is not a / then
+ files="$files `pwd`/$i" #it is a relative path so we must make it absolute.
+ elif [ "$i" != "-" ]; then
+ files="$files $i"
+ else
+ case "$i" in
+ --reconf|--help|-h)
+ ;;
+ *)
+ files="$files $i"
+ ;;
+ esac
+ fi
+done
diff --git a/app-editors/jext/jext-5.0.ebuild b/app-editors/jext/jext-5.0.ebuild
new file mode 100644
index 000000000000..00c30f80b226
--- /dev/null
+++ b/app-editors/jext/jext-5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-5.0.ebuild,v 1.1 2009/06/11 22:32:43 caster Exp $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A cool and fully featured editor in Java"
+HOMEPAGE="http://www.jext.org/"
+MY_PV="${PV/_}"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-sources-${MY_PV}.tar.gz"
+LICENSE="|| ( GPL-2 JPython )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/jython:0
+ dev-java/jgoodies-looks:1.2
+ dev-java/gnu-regexp:1"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}-src-${MY_PV}"
+
+java_prepare() {
+ rm -v "${S}"/extplugins/Admin/*.jar || die
+ # bundles some com.microstar.xml who knows what's that
+ # also com.jgoodies.uif_lite which is apparently some jgoodies-looks
+ # example code which we don't package and there is probably no point
+ rm -rf src/lib/gnu || die
+}
+
+src_compile() {
+ cd "${S}/src"
+ eant jar $(use_doc javadocs) \
+ -Dclasspath="$(java-pkg_getjars jython,jgoodies-looks-1.2,gnu-regexp-1)"
+}
+
+src_install () {
+ java-pkg_newjar lib/${P}.jar
+ java-pkg_dojar lib/dawn*.jar
+
+ java-pkg_dolauncher ${PN} \
+ --main org.jext.Jext \
+ --java_args '-Dpython.path=$(java-config --classpath=jython)' \
+ -pre "${FILESDIR}/${PN}-pre"
+
+ use doc && java-pkg_dohtml -A .css .gif .jpg -r docs/api
+}
+
+pkg_postinst() {
+ elog "Plugins are currently not built/installed. Patches welcome."
+} \ No newline at end of file