summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-21 23:23:27 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-21 23:23:27 +0000
commit0b0b30de70475b1fd6c823ae9233071464758cac (patch)
tree8d3920d176be683e12338b7370ac0ae2579236c2 /app-editors/levee
parentVersion bump (diff)
downloadgentoo-2-0b0b30de70475b1fd6c823ae9233071464758cac.tar.gz
gentoo-2-0b0b30de70475b1fd6c823ae9233071464758cac.tar.bz2
gentoo-2-0b0b30de70475b1fd6c823ae9233071464758cac.zip
Adding patch to allow building with glibc 2.10, closes bug #273848
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors/levee')
-rw-r--r--app-editors/levee/ChangeLog6
-rw-r--r--app-editors/levee/files/levee-3.5-glibc210.patch80
-rw-r--r--app-editors/levee/levee-3.5.ebuild6
3 files changed, 89 insertions, 3 deletions
diff --git a/app-editors/levee/ChangeLog b/app-editors/levee/ChangeLog
index e198c9ea139a..36baf685b182 100644
--- a/app-editors/levee/ChangeLog
+++ b/app-editors/levee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/levee
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.16 2009/06/05 16:00:37 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.17 2009/07/21 23:23:27 vostorga Exp $
+
+ 21 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> levee-3.5.ebuild,
+ +files/levee-3.5-glibc210.patch:
+ Adding patch to allow building with glibc 2.10, closes bug #273848
05 Jun 2009; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Retiring, bug 220219.
diff --git a/app-editors/levee/files/levee-3.5-glibc210.patch b/app-editors/levee/files/levee-3.5-glibc210.patch
new file mode 100644
index 000000000000..51cc829cda25
--- /dev/null
+++ b/app-editors/levee/files/levee-3.5-glibc210.patch
@@ -0,0 +1,80 @@
+diff -NrU5 levee-3.5.original/editcor.c levee-3.5/editcor.c
+--- levee-3.5.original/editcor.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/editcor.c 2009-07-21 23:07:21.000000000 +0000
+@@ -183,11 +183,11 @@
+
+ strcpy(scratch, "/tmp/lv.XXXXXX");
+
+ clrprompt();
+ printch('!');
+- if ( !getline(instring) )
++ if ( !get_line(instring) )
+ return FALSE;
+
+ if ( (tf = mkstemp(scratch)) < 0 ) {
+ prints("[tempfile error]");
+ return FALSE;
+diff -NrU5 levee-3.5.original/extern.h levee-3.5/extern.h
+--- levee-3.5.original/extern.h 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/extern.h 2009-07-21 23:02:39.000000000 +0000
+@@ -195,11 +195,11 @@
+ extern exec_type PROC editcore();
+
+ extern char PROC line(), peekc(), readchar();
+ extern char PROC *findparse(),*makepat();
+
+-extern bool PROC getline();
++extern bool PROC get_line();
+ extern bool PROC putfile();
+ extern bool PROC doyank(), deletion(), putback();
+ extern bool PROC pushb(),pushi(),pushmem(),uputcmd(), delete_to_undo();
+ extern bool PROC ok_to_scroll(), move_to_undo();
+
+diff -NrU5 levee-3.5.original/main.c levee-3.5/main.c
+--- levee-3.5.original/main.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/main.c 2009-07-21 23:09:52.000000000 +0000
+@@ -251,11 +251,11 @@
+ println();
+
+ mode=emode;
+ do {
+ prompt(FALSE,":");
+- if (getline(instring))
++ if (get_line(instring))
+ exec(instring, &mode, &noquit);
+ indirect = FALSE;
+ if (mode == E_VISUAL && zotscreen && noquit) { /*ask for more*/
+ prints(" [more]");
+ if ((ch=peekc()) == 13 || ch == ' ' || ch == ':')
+diff -NrU5 levee-3.5.original/misc.c levee-3.5/misc.c
+--- levee-3.5.original/misc.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/misc.c 2009-07-21 23:09:10.000000000 +0000
+@@ -19,11 +19,11 @@
+ */
+ #include "levee.h"
+ #include "extern.h"
+
+ bool PROC
+-getline(str)
++get_line(str)
+ char *str;
+ {
+ int len;
+ char flag;
+
+diff -NrU5 levee-3.5.original/move.c levee-3.5/move.c
+--- levee-3.5.original/move.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/move.c 2009-07-21 23:10:26.000000000 +0000
+@@ -158,11 +158,11 @@
+ case FSEARCH:
+ case BSEARCH:
+ clrprompt();
+ if (cmd == PATT_FWD || cmd == PATT_BACK) {
+ printch(tsearch = instring[0] = chars[cmd-PATT_FWD]);
+- if (!getline(&instring[1]))
++ if (!get_line(&instring[1]))
+ return ESCAPED; /* needs to skip later tests */
+ }
+ else {
+ if (!lsearch)
+ return BADMOVE;
diff --git a/app-editors/levee/levee-3.5.ebuild b/app-editors/levee/levee-3.5.ebuild
index b4276bdff909..39a720c207c9 100644
--- a/app-editors/levee/levee-3.5.ebuild
+++ b/app-editors/levee/levee-3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5.ebuild,v 1.2 2008/12/03 11:57:14 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5.ebuild,v 1.3 2009/07/21 23:23:27 vostorga Exp $
inherit toolchain-funcs eutils
@@ -15,11 +15,13 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
DEPEND="!app-text/lv
sys-libs/ncurses"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-QA.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
}
src_compile() {