summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-01 17:28:28 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-01 17:28:28 +0000
commit772b286ae0068bd437644154b4231dea62e0d645 (patch)
tree3ef56338bf6bf385e0de200fa6ec61f0cfa950be /app-editors/nano/nano-1.0.9-r2.ebuild
parentSome gimmicks added (diff)
downloadgentoo-2-772b286ae0068bd437644154b4231dea62e0d645.tar.gz
gentoo-2-772b286ae0068bd437644154b4231dea62e0d645.tar.bz2
gentoo-2-772b286ae0068bd437644154b4231dea62e0d645.zip
symlink fix for #10916
Diffstat (limited to 'app-editors/nano/nano-1.0.9-r2.ebuild')
-rw-r--r--app-editors/nano/nano-1.0.9-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/nano/nano-1.0.9-r2.ebuild b/app-editors/nano/nano-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..ca54f8daa80a
--- /dev/null
+++ b/app-editors/nano/nano-1.0.9-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.9-r2.ebuild,v 1.1 2002/12/01 17:27:29 vapier Exp $
+
+DESCRIPTION="clone of Pico with more functions in a smaller size"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+IUSE="nls build slang"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--bindir=/bin --enable-extra"
+ use nls || myconf="${myconf} --disable-nls"
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ use build \
+ && rm -rf ${D}/usr/share \
+ || dodoc COPYING ChangeLog README
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}