summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-11-27 20:50:36 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-11-27 20:50:36 +0000
commit50b21aef7848a0aeec0cfa1b195d1000c320684b (patch)
tree91dbdead7a50abdfe6b5435fa6dce09433d69a4c /app-editors/nano
parentAdded ~ppc64 to KEYWORDS; bug #72248 (Manifest recommit) (diff)
downloadgentoo-2-50b21aef7848a0aeec0cfa1b195d1000c320684b.tar.gz
gentoo-2-50b21aef7848a0aeec0cfa1b195d1000c320684b.tar.bz2
gentoo-2-50b21aef7848a0aeec0cfa1b195d1000c320684b.zip
Fix compilation because of conflicting types of break_line()
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog6
-rw-r--r--app-editors/nano/files/nano-1.3.5-break_line.patch11
-rw-r--r--app-editors/nano/nano-1.3.5.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 0a6bacb72e7c..5dd47ebf5776 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/nano
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.65 2004/11/23 03:27:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.66 2004/11/27 20:50:36 eradicator Exp $
+
+ 27 Nov 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/nano-1.3.5-break_line.patch, nano-1.3.5.ebuild:
+ Fix compilation because of conflicting types of break_line()
*nano-1.3.5 (22 Nov 2004)
diff --git a/app-editors/nano/files/nano-1.3.5-break_line.patch b/app-editors/nano/files/nano-1.3.5-break_line.patch
new file mode 100644
index 000000000000..d1eb373bcb09
--- /dev/null
+++ b/app-editors/nano/files/nano-1.3.5-break_line.patch
@@ -0,0 +1,11 @@
+--- src/nano.c.orig 2004-11-27 12:47:32.196155971 -0800
++++ src/nano.c 2004-11-27 12:47:47.815508571 -0800
+@@ -2399,7 +2399,7 @@
+ * such space, and force is TRUE, then we find the first space. Anyway,
+ * we then take the last space in that group of spaces. The terminating
+ * '\0' counts as a space. */
+-int break_line(const char *line, ssize_t goal, bool force)
++ssize_t break_line(const char *line, ssize_t goal, bool force)
+ {
+ ssize_t space_loc = -1;
+ /* Current tentative return value. Index of the last space we
diff --git a/app-editors/nano/nano-1.3.5.ebuild b/app-editors/nano/nano-1.3.5.ebuild
index 861e5fd67cee..75de82d3cc80 100644
--- a/app-editors/nano/nano-1.3.5.ebuild
+++ b/app-editors/nano/nano-1.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.5.ebuild,v 1.1 2004/11/23 03:27:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.5.ebuild,v 1.2 2004/11/27 20:50:36 eradicator Exp $
inherit eutils
@@ -25,6 +25,7 @@ src_unpack() {
unpack ${A}
cd ${S}
use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
+ epatch ${FILESDIR}/${P}-break_line.patch
}
src_compile() {