summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2008-10-05 14:52:40 +0000
committerHarald van Dijk <truedfx@gentoo.org>2008-10-05 14:52:40 +0000
commit0ba9bdad91257b23a7755a5509e14dc6ffbde7a2 (patch)
treec840048404969b45568319fa6550573d78714e1b /app-editors/nvi
parentMask tcl flag on nvi-1.81.6-r*, not only 1.81.6 (diff)
downloadgentoo-2-0ba9bdad91257b23a7755a5509e14dc6ffbde7a2.tar.gz
gentoo-2-0ba9bdad91257b23a7755a5509e14dc6ffbde7a2.tar.bz2
gentoo-2-0ba9bdad91257b23a7755a5509e14dc6ffbde7a2.zip
Respect user CFLAGS (bug #239931 by Diego Pettenò)
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-editors/nvi')
-rw-r--r--app-editors/nvi/ChangeLog7
-rw-r--r--app-editors/nvi/nvi-1.81.6-r1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-editors/nvi/ChangeLog b/app-editors/nvi/ChangeLog
index ae6e3554f97f..5ed26df16efa 100644
--- a/app-editors/nvi/ChangeLog
+++ b/app-editors/nvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nvi
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.64 2008/07/05 04:24:06 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.65 2008/10/05 14:52:40 truedfx Exp $
+
+*nvi-1.81.6-r1 (05 Oct 2008)
+
+ 05 Oct 2008; Harald van Dijk <truedfx@gentoo.org> +nvi-1.81.6-r1.ebuild:
+ Respect user CFLAGS (bug #239931 by Diego Pettenò)
05 Jul 2008; <ricmm@gentoo.org> nvi-1.81.5-r3.ebuild,
nvi-1.81.5-r6.ebuild:
diff --git a/app-editors/nvi/nvi-1.81.6-r1.ebuild b/app-editors/nvi/nvi-1.81.6-r1.ebuild
new file mode 100644
index 000000000000..6e6206620c66
--- /dev/null
+++ b/app-editors/nvi/nvi-1.81.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6-r1.ebuild,v 1.1 2008/10/05 14:52:40 truedfx Exp $
+
+DESCRIPTION="Vi clone"
+HOMEPAGE="http://www.bostic.com/vi/"
+SRC_URI="http://www.kotnet.org/~skimo/nvi/devel/${P}.tar.bz2"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl tcl unicode"
+
+DEPEND="=sys-libs/db-4*
+ perl? ( dev-lang/perl )
+ tcl? ( !unicode? ( >=dev-lang/tcl-8.5 ) )"
+RDEPEND="${DEPEND}
+ app-admin/eselect-vi"
+
+S=${WORKDIR}/${P}/build.unix
+
+pkg_setup() {
+ if use tcl && use unicode
+ then
+ ewarn "nvi does not support tcl+unicode. tcl support will not be included."
+ ewarn "If you need tcl support, please disable the unicode flag."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ chmod +x ../dist/findconfig
+}
+
+src_compile() {
+ local myconf
+
+ use perl && myconf="${myconf} --enable-perlinterp"
+ use tcl && ! use unicode && myconf="${myconf} --enable-tclinterp"
+ use unicode && myconf="${myconf} --enable-widechar"
+
+ ECONF_SOURCE=../dist econf \
+ --program-prefix=n \
+ ${myconf} \
+ || die "configure failed"
+ emake OPTFLAG="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/vi symlink"
+ eselect vi update --if-unset
+}