summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-20 11:45:33 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-20 11:45:33 +0000
commit456692de63f3d11ca988acd1add9d23f40c12689 (patch)
treea3876a14148a29b7e3ed2f82359d3390ab4f9334 /app-editors/qemacs/qemacs-0.3.1-r1.ebuild
parentVersion bumped. This closes bug #78999. (diff)
downloadgentoo-2-456692de63f3d11ca988acd1add9d23f40c12689.tar.gz
gentoo-2-456692de63f3d11ca988acd1add9d23f40c12689.tar.bz2
gentoo-2-456692de63f3d11ca988acd1add9d23f40c12689.zip
Added a patch to enable users to choose whether to create ~ backup file. This closes bug #75052.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-editors/qemacs/qemacs-0.3.1-r1.ebuild')
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..1a3da3a8c127
--- /dev/null
+++ b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.1 2005/02/20 11:45:33 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor."
+HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
+SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="X png unicode"
+
+DEPEND="X? ( virtual/x11 )
+ png? ( =media-libs/libpng-1.2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
+ epatch ${FILESDIR}/${P}-configure-gentoo.patch
+ epatch ${FILESDIR}/${P}-make_backup.patch
+ use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
+}
+
+src_compile() {
+ local myconf
+ use X && myconf="--enable-x11" || myconf="--disable-x11"
+ use png && myconf="${myconf} --enable-png" || myconf="${myconf} --disable-png"
+ econf ${myconf} || die "econf failed"
+ emake -j1 || die
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall || die
+ doman qe.1
+ dodoc Changelog README TODO VERSION
+ dohtml *.html
+}