summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-09 16:17:00 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-09 16:17:00 +0000
commit1caa1a1c36474081dff6e253c60e33316aae9000 (patch)
treed2d0fa58e1c4fe3a495e61b07239849f78b8b1d4 /app-editors/qxmledit
parentVersun bump (diff)
downloadgentoo-2-1caa1a1c36474081dff6e253c60e33316aae9000.tar.gz
gentoo-2-1caa1a1c36474081dff6e253c60e33316aae9000.tar.bz2
gentoo-2-1caa1a1c36474081dff6e253c60e33316aae9000.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog7
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index c61f5b25a50b..1fc33231f5b2 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.31 2012/05/25 17:07:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.32 2012/06/09 16:17:00 hwoarang Exp $
+
+*qxmledit-0.8.2 (09 Jun 2012)
+
+ 09 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +qxmledit-0.8.2.ebuild:
+ Version bump
25 May 2012; Agostino Sarubbo <ago@gentoo.org> -qxmledit-0.8.0-r1.ebuild,
qxmledit-0.8.1.ebuild:
diff --git a/app-editors/qxmledit/qxmledit-0.8.2.ebuild b/app-editors/qxmledit/qxmledit-0.8.2.ebuild
new file mode 100644
index 000000000000..b9bcc656d77f
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.8.2.ebuild,v 1.1 2012/06/09 16:17:00 hwoarang Exp $
+
+EAPI=4
+
+inherit multilib eutils qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-svg-4.7:4
+ >=x11-libs/qt-xmlpatterns-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README ROADMAP TODO"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/INST_DOC_DIR = / s|/opt/${PN}|/usr/share/doc/${PF}|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix doc installation path"
+ # fix binary installation path
+ sed -i "/INST_DIR = / s|/opt/${PN}|/usr/bin|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix binary installation path"
+ # fix helper libraries installation path
+ sed -i "/INST_LIB_DIR = / s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix library installation path"
+ # fix translations
+ sed -i "/INST_DATA_DIR = / s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix translations"
+ # fix include
+ sed -i "/INST_INCLUDE_DIR = / s|/opt|/usr/share|" src/QXmlEditWidget.pro \
+ || die "failed to fix include directory"
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}