summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-08-02 23:27:22 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-08-02 23:27:22 +0000
commitda9739f043c6c65d8755c3d143142163568c8a70 (patch)
treed6396acfcf5477edbb88ba0bf756bf665282b271 /app-editors/scite
parentversion bump (diff)
downloadgentoo-2-da9739f043c6c65d8755c3d143142163568c8a70.tar.gz
gentoo-2-da9739f043c6c65d8755c3d143142163568c8a70.tar.bz2
gentoo-2-da9739f043c6c65d8755c3d143142163568c8a70.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog8
-rw-r--r--app-editors/scite/files/scite-1.79-install.patch20
-rw-r--r--app-editors/scite/files/scite-1.79-no-lua.patch15
-rw-r--r--app-editors/scite/scite-1.79.ebuild77
4 files changed, 119 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index c6d1e65358cb..1c51d69f4b26 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.85 2009/07/25 10:15:26 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.86 2009/08/02 23:27:22 nelchael Exp $
+
+*scite-1.79 (02 Aug 2009)
+
+ 02 Aug 2009; Krzysiek Pawlik <nelchael@gentoo.org> +scite-1.79.ebuild,
+ +files/scite-1.79-install.patch, +files/scite-1.79-no-lua.patch:
+ Version bump.
25 Jul 2009; Krzysiek Pawlik <nelchael@gentoo.org> -scite-1.76.ebuild,
-files/scite-1.76-install.patch, -files/scite-1.76-no-lua.patch,
diff --git a/app-editors/scite/files/scite-1.79-install.patch b/app-editors/scite/files/scite-1.79-install.patch
new file mode 100644
index 000000000000..52f51e65b676
--- /dev/null
+++ b/app-editors/scite/files/scite-1.79-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 755 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/files/scite-1.79-no-lua.patch b/app-editors/scite/files/scite-1.79-no-lua.patch
new file mode 100644
index 000000000000..2511cef0faf9
--- /dev/null
+++ b/app-editors/scite/files/scite-1.79-no-lua.patch
@@ -0,0 +1,15 @@
+--- scite/src/SciTEProps.cxx 2008-04-05 17:23:22.000000000 +0200
++++ scite/src/SciTEProps.cxx 2008-04-05 17:23:41.000000000 +0200
+@@ -1461,10 +1461,12 @@
+
+ // return the int value of the command name passed in.
+ int SciTEBase::GetMenuCommandAsInt(SString commandName) {
++#ifndef NO_LUA
+ int i = IFaceTable::FindConstant(commandName.c_str());
+ if (i != -1) {
+ return IFaceTable::constants[i].value;
+ }
++#endif
+ // Otherwise we might have entered a number as command to access a "SCI_" command
+ return commandName.value();
+ }
diff --git a/app-editors/scite/scite-1.79.ebuild b/app-editors/scite/scite-1.79.ebuild
new file mode 100644
index 000000000000..29ec85d2c2ad
--- /dev/null
+++ b/app-editors/scite/scite-1.79.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.79.ebuild,v 1.1 2009/08/02 23:27:22 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${P}-install.patch"
+ epatch "${FILESDIR}/${P}-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}