summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-04 01:02:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-04 01:02:31 +0000
commit1fd4febd47a3d6c6b09674982547477d553609e1 (patch)
tree04e1a4ac5802eff0585249b2c4911f20b7394675 /app-editors/ted
parentfix building even without /usr/X11R6 (diff)
downloadgentoo-2-1fd4febd47a3d6c6b09674982547477d553609e1.tar.gz
gentoo-2-1fd4febd47a3d6c6b09674982547477d553609e1.tar.bz2
gentoo-2-1fd4febd47a3d6c6b09674982547477d553609e1.zip
remove useless BUILDDIR usage
(Portage version: 2.0.51.21)
Diffstat (limited to 'app-editors/ted')
-rw-r--r--app-editors/ted/ted-2.12-r1.ebuild5
-rw-r--r--app-editors/ted/ted-2.12.ebuild6
-rw-r--r--app-editors/ted/ted-2.17.ebuild22
3 files changed, 13 insertions, 20 deletions
diff --git a/app-editors/ted/ted-2.12-r1.ebuild b/app-editors/ted/ted-2.12-r1.ebuild
index f62cfc2a87ef..b7d415dd582f 100644
--- a/app-editors/ted/ted-2.12-r1.ebuild
+++ b/app-editors/ted/ted-2.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12-r1.ebuild,v 1.1 2005/03/28 22:41:06 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12-r1.ebuild,v 1.2 2005/05/04 01:02:31 vapier Exp $
DESCRIPTION="X-based rich text editor."
HOMEPAGE="http://www.nllgg.nl/Ted"
@@ -44,14 +44,11 @@ src_compile() {
src_install() {
# This is a fix for userpriv &| usersandbox.
export RPM_BUILD_ROOT="${S}"
- cd ${BUILDDIR}
mkdir ${T}/pkg
cd ${T}/pkg || die "Couldn't cd to package"
tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
- cd ${BUILDDIR}
-
dodir /usr/share/Ted
cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
diff --git a/app-editors/ted/ted-2.12.ebuild b/app-editors/ted/ted-2.12.ebuild
index 844d69ca6a63..7c2e850efa84 100644
--- a/app-editors/ted/ted-2.12.ebuild
+++ b/app-editors/ted/ted-2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.11 2005/01/01 13:34:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.12 2005/05/04 01:02:31 vapier Exp $
DESCRIPTION="X-based rich text editor."
HOMEPAGE="http://www.nllgg.nl/Ted"
@@ -40,14 +40,10 @@ src_compile() {
}
src_install() {
- cd ${BUILDDIR}
-
mkdir ${T}/pkg
cd ${T}/pkg || die "Couldn't cd to package"
tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
- cd ${BUILDDIR}
-
dodir /usr/share/Ted
cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
diff --git a/app-editors/ted/ted-2.17.ebuild b/app-editors/ted/ted-2.17.ebuild
index 435bc56d49eb..cc800a2744d1 100644
--- a/app-editors/ted/ted-2.17.ebuild
+++ b/app-editors/ted/ted-2.17.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17.ebuild,v 1.1 2005/03/31 09:01:43 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.17.ebuild,v 1.2 2005/05/04 01:02:31 vapier Exp $
-DESCRIPTION="X-based rich text editor."
+DESCRIPTION="X-based rich text editor"
HOMEPAGE="http://www.nllgg.nl/Ted"
SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
IUSE=""
-KEYWORDS="~x86 ~ppc ~sparc"
DEPEND="x11-libs/openmotif
>=media-libs/tiff-3.5.7
@@ -20,9 +20,10 @@ S="${WORKDIR}/Ted-${PV}"
src_unpack() {
unpack ${A}
- cd ${S}/Ted
- mv makefile.in makefile.in.orig
- sed 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' makefile.in.orig > makefile.in
+ cd "${S}"/Ted
+ sed -i \
+ -e 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' \
+ makefile.in
}
src_compile() {
@@ -36,22 +37,21 @@ src_compile() {
# The makefile doesn't really allow parallel make, but it does
# no harm either.
cd ${S}
- emake DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
+ emake \
+ DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
- package.shared || die "couldnt emake"
+ package.shared \
+ || die "couldnt emake"
}
src_install() {
# This is a fix for userpriv &| usersandbox.
export RPM_BUILD_ROOT="${S}"
- cd ${BUILDDIR}
mkdir ${T}/pkg
cd ${T}/pkg || die "Couldn't cd to package"
tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
- cd ${BUILDDIR}
-
dodir /usr/share/Ted
cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"