summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-19 18:21:39 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-19 18:21:39 +0000
commit0606438f805bcc2e696eed184c9261a1096d9ce0 (patch)
tree49fe77cec5bfe6a7b8c9e8a98a48e73806911cfb /app-editors
parentKeyword amd64-linux and x86-linux (diff)
downloadgentoo-2-0606438f805bcc2e696eed184c9261a1096d9ce0.tar.gz
gentoo-2-0606438f805bcc2e696eed184c9261a1096d9ce0.tar.bz2
gentoo-2-0606438f805bcc2e696eed184c9261a1096d9ce0.zip
Revision bump syncs with kde overlay ebuild state. EAPI 5 and less code.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kile/ChangeLog9
-rw-r--r--app-editors/kile/kile-2.1.3-r1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 4847c50a090e..b1b3c901f328 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/kile
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.165 2012/12/10 17:04:49 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.166 2014/03/19 18:21:39 johu Exp $
+
+*kile-2.1.3-r1 (19 Mar 2014)
+
+ 19 Mar 2014; Johannes Huber <johu@gentoo.org> +kile-2.1.3-r1.ebuild:
+ Revision bump syncs with kde overlay ebuild state. EAPI 5 and less code.
10 Dec 2012; Michael Palimaka <kensington@gentoo.org> kile-2.1.3.ebuild:
Drop ppc64 keyword due to unkeyworded required dependencies.
diff --git a/app-editors/kile/kile-2.1.3-r1.ebuild b/app-editors/kile/kile-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..9be500c5c426
--- /dev/null
+++ b/app-editors/kile/kile-2.1.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.1.3-r1.ebuild,v 1.1 2014/03/19 18:21:39 johu Exp $
+
+EAPI=5
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+MY_P=${P/_beta/b}
+inherit kde4-base
+
+DESCRIPTION="A Latex Editor and TeX shell for KDE"
+HOMEPAGE="http://kile.sourceforge.net/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="debug +pdf +png"
+
+DEPEND="
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdebase-data)
+ || (
+ $(add_kdebase_dep okular 'pdf?,postscript')
+ app-text/acroread
+ )
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/dvipdfmx
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ media-gfx/imagemagick[png]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+
+ [[ ${PV} != *9999* ]] && { use handbook || rm -fr doc ; }
+}