summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-28 22:43:09 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-28 22:43:09 +0000
commit08f7d823ec21db76f0ab4ffaea1b0d7d93e0dcca (patch)
tree4b623eef8686c01485e36dadc64c4ed36f730d6c /app-editors
parentRemove odd USE=unicode. Fix building against sys-libs/ncurses[tinfo] (bug #48... (diff)
downloadgentoo-2-08f7d823ec21db76f0ab4ffaea1b0d7d93e0dcca.tar.gz
gentoo-2-08f7d823ec21db76f0ab4ffaea1b0d7d93e0dcca.tar.bz2
gentoo-2-08f7d823ec21db76f0ab4ffaea1b0d7d93e0dcca.zip
Fix HOMEPAGE/SRC_URI. Remove parallel make workaround. Fix building against sys-libs/ncurses[tinfo] (bug #459548).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ne/ChangeLog7
-rw-r--r--app-editors/ne/metadata.xml9
-rw-r--r--app-editors/ne/ne-2.3.ebuild8
-rw-r--r--app-editors/ne/ne-2.5.ebuild39
4 files changed, 39 insertions, 24 deletions
diff --git a/app-editors/ne/ChangeLog b/app-editors/ne/ChangeLog
index 33c501ac7eb5..1e72a0997b2c 100644
--- a/app-editors/ne/ChangeLog
+++ b/app-editors/ne/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ne
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.50 2014/03/11 19:51:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.51 2014/10/28 22:43:09 jer Exp $
+
+ 28 Oct 2014; Jeroen Roovers <jer@gentoo.org> ne-2.3.ebuild, ne-2.5.ebuild,
+ metadata.xml:
+ Fix HOMEPAGE/SRC_URI. Remove parallel make workaround. Fix building against
+ sys-libs/ncurses[tinfo] (bug #459548).
11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #53266
diff --git a/app-editors/ne/metadata.xml b/app-editors/ne/metadata.xml
index aba833ed90e0..f3e7ae06bec6 100644
--- a/app-editors/ne/metadata.xml
+++ b/app-editors/ne/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='tinfo'>Link against libtinfo from sys-libs/ncurses</flag>
+</use>
</pkgmetadata>
diff --git a/app-editors/ne/ne-2.3.ebuild b/app-editors/ne/ne-2.3.ebuild
index 87f5df6df47e..b71835dd3615 100644
--- a/app-editors/ne/ne-2.3.ebuild
+++ b/app-editors/ne/ne-2.3.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.3.ebuild,v 1.5 2012/08/21 06:00:49 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.3.ebuild,v 1.6 2014/10/28 22:43:09 jer Exp $
EAPI="2"
inherit eutils toolchain-funcs
DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
-HOMEPAGE="http://ne.dsi.unimi.it/"
-SRC_URI="http://ne.dsi.unimi.it/${P}.tar.gz"
+HOMEPAGE="http://ne.di.unimi.it/"
+SRC_URI="http://ne.di.unimi.it/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-editors/ne/ne-2.5.ebuild b/app-editors/ne/ne-2.5.ebuild
index fe6011e02b30..502635bf26db 100644
--- a/app-editors/ne/ne-2.5.ebuild
+++ b/app-editors/ne/ne-2.5.ebuild
@@ -1,37 +1,44 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.5.ebuild,v 1.1 2014/01/07 08:37:33 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.5.ebuild,v 1.2 2014/10/28 22:43:09 jer Exp $
EAPI=5
-
inherit eutils toolchain-funcs
DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
-HOMEPAGE="http://ne.dsi.unimi.it/"
-SRC_URI="http://ne.dsi.unimi.it/${P}.tar.gz"
+HOMEPAGE="http://ne.di.unimi.it/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
+IUSE=tinfo
-RDEPEND=">=sys-libs/ncurses-5.2"
-DEPEND="${RDEPEND}
- dev-lang/perl"
+RDEPEND="
+ >=sys-libs/ncurses-5.2[tinfo?]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+"
src_prepare() {
sed -i -e 's/-O3//' src/makefile || die
}
+src_configure() {
+ if use tinfo; then
+ sed -i -e 's|-lcurses|-ltinfo|g' src/makefile || die
+ else
+ sed -i -e 's|-lcurses|-lncurses|g' src/makefile || die
+ fi
+}
+
src_compile() {
- emake \
- -j1 \
- -C src \
- ne \
- OPTS="${CFLAGS}" \
- CC="$(tc-getCC)" \
+ emake -C src CC="$(tc-getCC)" \
NE_GLOBAL_DIR="/usr/share/ne" \
- || die "emake failed"
+ OPTS="${CFLAGS}" \
+ ne || die
}
src_install() {