summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-28 19:11:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-28 19:11:11 +0000
commit1fe37bb4a90380a5a0cc717cf8176619b843fc29 (patch)
treed4ce352c3597c37da294a023f0821fd5531df375 /app-editors
parentx86 stable wrt security bug #410045. (diff)
downloadgentoo-2-1fe37bb4a90380a5a0cc717cf8176619b843fc29.tar.gz
gentoo-2-1fe37bb4a90380a5a0cc717cf8176619b843fc29.tar.bz2
gentoo-2-1fe37bb4a90380a5a0cc717cf8176619b843fc29.zip
version bump
(Portage version: 2.2.0_alpha94/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/ChangeLog7
-rw-r--r--app-editors/gummi/gummi-0.6.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index bdf8522d7f6a..dfd2610692ce 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.33 2012/03/18 10:06:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.34 2012/03/28 19:11:11 hwoarang Exp $
+
+*gummi-0.6.3 (28 Mar 2012)
+
+ 28 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +gummi-0.6.3.ebuild:
+ version bump
*gummi-0.6.2 (18 Mar 2012)
diff --git a/app-editors/gummi/gummi-0.6.3.ebuild b/app-editors/gummi/gummi-0.6.3.ebuild
new file mode 100644
index 000000000000..0e7e0a62f852
--- /dev/null
+++ b/app-editors/gummi/gummi-0.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.6.3.ebuild,v 1.1 2012/03/28 19:11:11 hwoarang Exp $
+
+EAPI=4
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/attachments/download/263/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ar ca cs da de el es fr it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell:2
+ >=dev-libs/glib-2.28.6
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}