summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-26 22:35:55 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-26 22:35:55 +0000
commit49f845a1c5e324cfdb669cc06e4fe5df32fcdb55 (patch)
tree976057309b1a59ba6c69993acf4e7afe50572aa5 /app-editors
parentVersion bump. Switch to out-of-source build. (diff)
downloadgentoo-2-49f845a1c5e324cfdb669cc06e4fe5df32fcdb55.tar.gz
gentoo-2-49f845a1c5e324cfdb669cc06e4fe5df32fcdb55.tar.bz2
gentoo-2-49f845a1c5e324cfdb669cc06e4fe5df32fcdb55.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog7
-rw-r--r--app-editors/bluefish/bluefish-2.2.3-r1.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 227c7d576eae..28aa7e91b9f2 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.91 2014/08/10 17:40:30 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.92 2014/12/26 22:35:55 mgorny Exp $
+
+*bluefish-2.2.3-r1 (26 Dec 2014)
+
+ 26 Dec 2014; Michał Górny <mgorny@gentoo.org> +bluefish-2.2.3-r1.ebuild:
+ Convert to python-single-r1.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> bluefish-2.2.2.ebuild,
bluefish-2.2.3.ebuild:
diff --git a/app-editors/bluefish/bluefish-2.2.3-r1.ebuild b/app-editors/bluefish/bluefish-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..21af45efc358
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2.2.3-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2.2.3-r1.ebuild,v 1.1 2014/12/26 22:35:55 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fdo-mime python-single-r1
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
+SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="nls python spell"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ gnome-extra/gucharmap:2.90
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spell? ( app-text/enchant )"
+DEPEND="${RDEPEND}
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ virtual/pkgconfig
+ x11-libs/pango
+ nls? (
+ sys-devel/gettext
+ dev-util/intltool
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+# there actually is just some broken manpage checkup -> not bother
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+# Never eautoreconf this package as gettext breaks completely (no translations
+# even if it compiles afterwards)!
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-dependency-tracking \
+ --disable-update-databases \
+ --disable-xml-catalog-update \
+ $(use_enable nls) \
+ $(use_enable spell spell-check) \
+ $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo "Adding XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ /etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "Removing XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ /etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}