summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-08-31 04:16:58 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-08-31 04:16:58 +0000
commit5fa9d989b5bacfc79c9d3dd0a375cedd5e1e0074 (patch)
tree4d2b10a3f9af7e9594f355224ea8a97479677160 /app-editors
parentx86 stable wrt security bug #330195 (diff)
downloadgentoo-2-5fa9d989b5bacfc79c9d3dd0a375cedd5e1e0074.tar.gz
gentoo-2-5fa9d989b5bacfc79c9d3dd0a375cedd5e1e0074.tar.bz2
gentoo-2-5fa9d989b5bacfc79c9d3dd0a375cedd5e1e0074.zip
Initial import. Based on ebuilds by Yoshi Watanabe and Philipp Richter in
bug #283994. (Portage version: 2.2_rc72/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/ChangeLog11
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch37
-rw-r--r--app-editors/wxhexeditor/metadata.xml8
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.09.ebuild32
4 files changed, 88 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/ChangeLog b/app-editors/wxhexeditor/ChangeLog
new file mode 100644
index 000000000000..9010cb22ccdb
--- /dev/null
+++ b/app-editors/wxhexeditor/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-editors/wxhexeditor
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+
+*wxhexeditor-0.09 (31 Aug 2010)
+
+ 31 Aug 2010; Ryan Hill <dirtyepic@gentoo.org> +wxhexeditor-0.09.ebuild,
+ +files/wxhexeditor-0.09-gcc45.patch, +metadata.xml:
+ Initial import. Based on ebuilds by Yoshi Watanabe and Philipp Richter in
+ bug #283994.
+
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
new file mode 100644
index 000000000000..c49e8a2452ca
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
@@ -0,0 +1,37 @@
+http://wxhexeditor.svn.sourceforge.net/viewvc/wxhexeditor/trunk/src/HexEditor.cpp?r1=132&r2=145
+
+--- a/src/HexEditor.cpp
++++ b/src/HexEditor.cpp
+@@ -102,7 +102,7 @@ bool HexEditor::FileOpen(wxFileName& myfilename ){
+ wxLogError(_("Critical Error. File pointer is not empty!"));
+ return false;
+ }
+- else if(myfilename.IsFileReadable()){ //IsFileReadable
++ else if( myfilename.IsFileReadable() ){ //IsFileReadable
+ if ( myfilename.GetSize( ) < 50*MB && myfilename.IsFileWritable() )
+ myfile = new FileDifference( myfilename, FileDifference::ReadWrite );
+ else
+@@ -869,20 +869,20 @@ void HexEditor::OnMouseTest( wxMouseEvent& event ){
+ }
+
+ void HexEditor::FindDialog( void ){
+- class FindDialog *myfind = new FindDialog::FindDialog( this, myfile );
++ ::FindDialog *myfind = new ::FindDialog( this, myfile );
+ myfind->ShowModal();
+ myfind->Destroy();
+ }
+
+ void HexEditor::ReplaceDialog( void ){
+- class ReplaceDialog *myfind = new ReplaceDialog::ReplaceDialog( this, myfile );
++ ::ReplaceDialog *myfind = new ::ReplaceDialog( this, myfile );
+ myfind->ShowModal();
+ myfind->Destroy();
+ }
+
+ void HexEditor::GotoDialog( void ){
+ uint64_t newoffset;
+- class GotoDialog *mygoto = new GotoDialog::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
++ ::GotoDialog *mygoto = new ::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
+ if( mygoto->ShowModal() == wxID_OK ){
+ Goto( newoffset );
+ }
diff --git a/app-editors/wxhexeditor/metadata.xml b/app-editors/wxhexeditor/metadata.xml
new file mode 100644
index 000000000000..1d5f99d169fe
--- /dev/null
+++ b/app-editors/wxhexeditor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <maintainer>
+ <email>wxwidgets@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild
new file mode 100644
index 000000000000..1cbe530d35a4
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+
+EAPI=3
+WX_GTK_VER=2.8
+
+inherit eutils wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files."
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}